hdu 2119 Matrix(二分图最大匹配)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2119

给你一个N*M的0/1矩阵,你每次可以选特定的某行或某列,然后删除该行/列的所有1,问你最少需要几次操作能删除矩阵的所有1.

Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.

 

 

Input

There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.

 

 

Output

For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.

 

 

Sample Input

 

3 3 0 0 0 1 0 1 0 1 0 0

 

 

Sample Output

 

2

 

前面有好几道类似的题,也没什么好说的了。是1的点,就i->j连边。

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<set>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 1010;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int n, m;
vector<int>vec[maxn];
int linker[maxn];
bool vis[maxn];
void init()
{
	for (int i = 0; i <= n; i++)
	{
		vec[i].clear();
	}
	return;
}
bool dfs(int x)
{
	for (int i = 0; i < vec[x].size(); i++)
	{
		int v = vec[x][i];
		if (!vis[v])
		{
			vis[v] = true;
			if (linker[v] == -1 || dfs(linker[v]))
			{
				linker[v] = x;
				return 1;
			}
		}
	}
	return 0;
}
int mx()
{
	int ans = 0;
	memset(linker, -1, sizeof(linker));
	for (int i = 1; i <= n; i++)
	{
		memset(vis, false, sizeof(vis));
		ans += dfs(i);
	}
	return ans;
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	while (scanf("%d", &n)&&n)
	{
		scanf("%d", &m);
		init();
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= m; j++)
			{
				int t;
				scanf("%d", &t);
				if (t)
				{
					vec[i].push_back(j);
				}
			}
		}
		int _max = mx();
		printf("%d\n", _max);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值