Hdu 2119 Matrix 二分图的最大匹配

                        

Matrix

Problem Description

Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .
Your task is to give out the minimum times of deleting all the '1' in the matrix.

Input

There are several test cases.
The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix. The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.
n=0 indicate the end of input.

Output

For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.

Sample Input

3 3 
0 0 0
1 0 1
0 1 0
0

Sample Output

//  比起 网络流 二分图 好学多了 -_-# .....
#include<cstdio>
#include<iostream>
#define M 110
int mark[M] , m ;
bool vi[M] ;
int cap[M][M] ;
using namespace std ;
bool find( int i ){
     int j ;
     for( j = 1 ;j <= m ; j++)
         if( vi[j] == 0 && cap[i][j] == 1 )
     {
           vi[j] = 1 ; 
           if( mark[j] == -1 || find( mark[j] )){ // j 没有 匹配  或者找到增广轨 
               mark[j] = i ;  
               return 1 ;
           }
     }
         return 0 ;
}
int main()
{
    int i , j , n , sum ;
    while( scanf( "%d" , &n ) && n != 0  ){
        scanf( "%d" , &m ) ;
        sum = 0 ;
        memset( mark , -1 , sizeof(mark)) ;
        for( i = 1 ; i <= n ; i++)
            for( j = 1 ; j <= m ; j++){
                scanf( "%d" , &cap[i][j] ) ;
            }

        for( i = 1 ; i <= n ;i++){

               memset( vi , 0 , sizeof(vi) ) ;
            if( find( i ) ) sum++ ;
        }
        cout << sum << endl ;
    }
}

 

 

转载于:https://www.cnblogs.com/20120125llcai/archive/2013/03/28/2987212.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值