hdu 2767 Proving Equivalences (tajan)强联通

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2767

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

 

 

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

 

 

Output

Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

 

 

Sample Input

 

2 4 0 3 2 1 2 1 3

 

 

Sample Output

 

4 2

 

给一张图,问需要添加几条边,使得图变成强联通图

先求这张图的强连通分量,如果为1,则输出0(证明该图不需要加边已经是强连通的了),否则缩点。遍历原图的所有边,如果2个点在不同的强连通分量里面,建边,构成一张新图。统计新图中点的入度和出度,取入度等于0和出度等于0的最大值(因为求强连通缩点后,整张图就变成了一个无回路的有向图,要使之强连通,只需要将入度=0和出度=0的点加边即可,要保证加边后没有入度和出度为0的点,所以取两者最大值)

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<set>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 1e5 + 100;
const int inf = 0x3f3f3f3f;
typedef long long ll;
struct node
{
	int u, v, next;
}edge[maxn];
int dfn[maxn], low[maxn], Stack[maxn], instack[maxn], belong[maxn];
int head[maxn], in[maxn], ou[maxn];
int tot, n, m, index, cnt, stop;
void init()
{
	memset(head, -1, sizeof(head));
	memset(dfn, 0, sizeof(dfn));
	memset(low, 0, sizeof(low));
	memset(in, 0, sizeof(in));
	memset(ou, 0, sizeof(ou));
	memset(Stack, 0, sizeof(Stack));
	memset(instack, 0, sizeof(instack));
	memset(belong, 0, sizeof(belong));
	index = tot = 0;
	stop = cnt = 0;
	return;
}
void addedge(int u, int v)
{
	edge[tot].u = u;
	edge[tot].v = v;
	edge[tot].next = head[u];
	head[u] = tot++;
	return;
}
void tarjan(int u)
{
	dfn[u] = low[u] = ++index;
	instack[u] = 1;
	Stack[stop++] = u;
	for (int i = head[u]; i != -1; i = edge[i].next)
	{
		int v = edge[i].v;
		if (!dfn[v])
		{
			tarjan(v);
			low[u] = min(low[u], low[v]);
		}
		else if (instack[v])
		{
			low[u] = min(low[u], dfn[v]);
		}
	}
	if (low[u] == dfn[u])
	{
		cnt++; 
		int v;
		do 
		{
			v = Stack[--stop];
			instack[v] = 0;
			belong[v] = cnt;
		} while (u != v);
	}
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d", &n, &m); 
		init();
		int incnt, oucnt;
		incnt = oucnt = 0;
		for (int i = 1; i <= m; i++)
		{
			int u, v;
			scanf("%d%d", &u, &v);
			addedge(u, v);
		}
		for (int i = 1; i <= n; i++)
		{
			if (!dfn[i])
			{
				tarjan(i);
			}
		}
		if (cnt == 1)
		{
			printf("0\n");
			continue;
		}
		for (int i = 1; i <= n; i++)
		{
			for (int j = head[i]; j != -1; j = edge[j].next)
			{
				int v = edge[j].v;
				if (belong[v] != belong[i])
				{
					in[belong[v]]++;
					ou[belong[i]]++;
				}
			}
		}
		for (int i = 1; i <= cnt; i++)
		{
			if (!in[i])
			{
				incnt++;
			}
			if (!ou[i])
			{
				oucnt++;
			}
		}
		printf("%d\n", max(incnt, oucnt));
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值