HDU 2767 Proving Equivalences

这篇博客探讨了在HDU 2767问题中如何运用算法和遍历技术来证明等价关系,主要关注ACM竞赛中的算法策略和栈的应用。
摘要由CSDN通过智能技术生成


Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3676    Accepted Submission(s): 1352


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

Sample Input
  
  
2 4 0 3 2 1 2 1 3
 

Sample Output
  
  
4 2
 

Source

题意:给你n个关系,m条推导,问你最少需要添加几条推导才能使任意两个关系之间可以互推。
然后这个问题便转化成一幅图,需要添加几条边,使得这个图变成强连通图。
思路:首先用tarjan把图变成DAG图,然后统计没有被连上的点(入度出度为0)。找最大的入度和出度,即代表最少需要添加几条边。
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <stack>
using namespace std;
#define MAXN 200010
#define clr(x,k) memset((x),(k),sizeof(x))
struct node
{
    int st,to,next;
}
edge[MAXN];
int n,m,ct,id;
int head[MAXN],low[MAXN],dfn[MAXN],belong[MAXN],in[MAXN],to[MAXN];
//DFN[i]表示 遍历到 i 点时是第几次dfs
//Low[u] 表示 以u点为父节点的 子树 能连接到 [栈中] 最上端的点 的DFN值
//belong存的是缩点后的点。
//ct 是指相互的点到达可以缩成一个点的个数。
bool instack[MAXN];
stack<int>q;
void add_e(int i,int u,int v)
{
    edge[i].st=u;
    edge[i].to=v;
    edge[i].next=head[u];
    head[u]=i;
}
void tarjan(int i)
{
    int j;
    dfn[i]=low[i]=++id;
    q.push(i);
    instack[i]=1;
    for(int u=head[i]; ~u; u=edge[u].next)  //求强连通分量
    {
        j=edge[u].to;
        if(dfn[j]==0)
        {
            tarjan(j);
            if(low[i]>low[j])
                low[i]=low[j];
        }
        else if(instack[j]&&low[i]>low[j])
            low[i]=dfn[j]; 
    }
    if(dfn[i]==low[i])  //缩点
    {
        ct++;
        do
        {
            j=q.top();
            q.pop();
            instack[j]=0;
            belong[j]=ct;
        }
        while(i!=j);
    }
}
int main()
{
    int t,i,u,v,sum1,sum2;
    cin>>t;
    while(t--)
    {
        clr(head,-1);
        clr(low,0);
        clr(dfn,0);
        clr(belong,0);
        clr(in,0);
        clr(to,0);
        while(!q.empty())
            q.pop();
        cin>>n>>m;
        for(i=0; i<m; i++)
        {
            cin>>u>>v;
            add_e(i,u,v);
        }
        id=ct=0;
        for(i=1; i<=n; i++)
        {
            if(!dfn[i])
                tarjan(i);
        }
        if(ct==1) //所有的点可以任意到达,原图即为强连通图。
        {
            cout<<0<<endl;
            continue;
        }
        for(i=1; i<=ct; i++)
        {
            in[i]=to[i]=0;
        }
        for(i=0; i<m; i++)
        {
            if(belong[edge[i].st]!=belong[edge[i].to])
            {
                in[belong[edge[i].st]]++;
                to[belong[edge[i].to]]++;
            }
        }
        sum1=sum2=0;
        for(i=1; i<=ct; i++)
        {
            if(in[i]==0)
                sum1++;
            if(to[i]==0)
                sum2++;
        }
        cout<<max(sum1,sum2)<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值