Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 48681 Accepted Submission(s): 17381
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5greenredblueredred3pinkorangepink0
Sample Output
redpink
解题思路:先用一个二维的字符数组储存输入的颜色,再用 strcmp 函数比较 查找相同的颜色,用一个整型数组(与每个字符数组的下标相同)记录颜色出现的次数。
代码:
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
int n , i , j ,num[1005] ;
char color[1005][16];
while(scanf("%d" ,&n)!=EOF)
{
if(n == 0)
break;
memset(num , 0 , sizeof(num));
for(i = 0 ; i < n ;i++)
scanf("%s" ,color[i]);
for(i = 0 ; i < n ; i++)//查找和记录出现的颜色的次数;
{
for(j = 0 ; j < n ; j++)
{
if(!strcmp(color[i] , color[j]))
num[i]++;//记录出现相同颜色的次数;
}
}
int max = 0, k;
for(i = 0 ; i < n ; i++)//找出出现次数最多的颜色;
{
if(max < num[i])
{
max = i ;
k = i;//记录下标;
}
}
printf("%s\n" ,color[k]);
}
return 0;
}