Let the Balloon Rise HDU

Let the Balloon Rise HDU Oj

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

其实英文看不明白只看输入输出也差不多明白让干嘛了。就是输入一个n,然后接着输入n个颜色,最后输出最多的那种颜色。

#include<bits/stdc++.h>
using namespace std;
struct colors{
    string name;
    int flag=0;

};

int main()
{

    int n;
    string color;
    while(cin>>n&&n!=0)
    {
    /*
    最开始把colors放在while外面,可以运行但输出不正确,应该是colors一次输入输出后不清空,导致里面有上一次的数据,这样后面的比较插入就会出现问题。后来让每一次while都重新定义colors,这样会造成内存浪费,但是AC了,有大神可以留言怎么改进一下
    */
        colors co[1000];//最开始把colors放在while外面,可以运行但输出不正确
        int t=0;
        for(int i=0;i<n;i++)
        {

            int f=0;//标记,验证是否已经存在这种颜色
            cin>>color;
            for(int j=0;j<t;j++)//循环看一下之前有没有存过这个元素
            {
                if(co[j].name==color)
                {
                    co[j].flag++;
                    f=1;
                    break;
                }
            }

            if(f==0)//如果之前没存过就存过去
            {
                co[t].name=color;
                t++;//t为colors中存储的下标,只有存入才会++
            }



        }
        int maxoftheflag=co[0].flag;int y=0;//flag开始既定为了颜色出现的次//数,y定义为第y个的flag最大,一个循环找出来谁的flag最大
        for(int x=0;x<=t-1;x++)
        {
             //cout<<"@"<<co[x].flag<<co[x].name;开始有问题,调试一下,colors里面的对否

            if(co[x].flag>maxoftheflag)
              {
                  maxoftheflag=co[x].flag;
                  y=x;
              }
        }
        //cout<<"    "<<y;
        //
        cout<<co[y].name<<endl;


    }


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值