Rightmost DigitTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 23184 Accepted Submission(s): 8836
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
Sample Output
|
//解题思路:N(1<=N<=1,000,000,000).范围比较大,所以这题应该是有规律的,所以先打表找规律;
#include <cstdio>
#include <cstring>
int main()
{
int num[25] = {0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
int i , j;
/*freopen("data.txt" ,"w" ,stdout);//打表找规律,发现每20个数的尾数都是相同的;用数组储存每一个数的尾数,然后直接输出
for(i = 1; i <= 100 ; i++)
{
int sum = 1;
for(j = 1 ; j <= i; j++)
{
sum *= i;
if(sum > 100)
sum %= 100;
}
printf("%d " ,sum%10);
if(i % 20 == 0)
printf("\n");
}*/
int n ;
while(scanf("%d" ,&n) != EOF)
{
int nums;
while(n--)
{
scanf("%d" ,&nums);
while(nums > 20)
{
nums %= 20;
}
printf("%d\n" , num[nums]);
}
}
}