易语言API时钟的使用方法

点击阅读原文





子程序:

.版本 2

.子程序 _时钟销毁, 逻辑型, 公开, 销毁一个时钟;成功返回真,失败返回假;
.参数 窗口句柄, 整数型, , 直接用“取窗口句柄()”命令取出本窗口句柄即可
.参数 时钟标识文本, 整数型, , 创建时用的标识文本
返回 (KillTimer (窗口句柄, 时钟标识文本))

    
.子程序 _时钟创建, 逻辑型, 公开, 创建一个时钟;成功返回真,失败返回假;
.参数 窗口句柄, 整数型, , 直接用“取窗口句柄()”命令取出本窗口句柄即可
.参数 时钟标识文本, 整数型, , 随便输入一些文本,销毁时用来辩认的;
.参数 时钟周期, 整数型, , 时钟周期
.参数 时钟_周期事件, 整数型, , 时钟_周期事件

返回 (SetTimer (窗口句柄, 时钟标识文本, 时钟周期, 时钟_周期事件))

DLL定义:

.版本 2


.DLL命令 KillTimer, 整数型, "user32", "KillTimer", , 中止定时器
    .参数 hwnd, 整数型
    .参数 nIDEvent, 整数型


.DLL命令 SetTimer, 整数型, "user32", "SetTimer", , 安装系统定时器
    .参数 hWnd, 整数型
    .参数 nIDEvent, 整数型
    .参数 uElapse, 整数型
    .参数 lpTimerFunc, 整数型


©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页