1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N < 100 0<N<100 0<N<100, the number of nodes in a tree, and M M M ( < N <N <N), the number of non-leaf nodes. Then M M M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N N N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题解

给出一棵树,计算每一层的叶子节点的个数。

可以用树的层序遍历做,也可以用dfs,但是dfs写起来比较快。用静态节点比较方便。

#include <iostream>
#include <vector>

using namespace std;

vector<int> nodes[105];
// leaf[i]:第i层的叶子结点的个数
// level[i]:结点i的层数
// maxLevel最大层数
int leaf[105], level[105], maxLevel;

void dfs(int root) {
    int l = level[root]; // 当深搜到root时,root的层数一定确定了

    if (l > maxLevel)
        maxLevel = l;

    if (nodes[root].size() == 0)      // 这个结点是叶子结点
        ++leaf[l];                    // 这层的叶子结点数+1
    else                              // 这个结点不是叶子节点
        for (auto &e : nodes[root]) { // 遍历他的孩子
            level[e] = l + 1;
            dfs(e);
        }
}
int main() {
    int n, m;

    cin >> n;

    if (n == 0)
        return 0;

    cin >> m;

    for (int i = 0; i < m; ++i) {
        int id, k;
        cin >> id >> k;

        for (int j = 0; j < k; ++j) {
            int c;
            cin >> c;

            nodes[id].push_back(c);
        }
    }

    level[1] = 0;

    dfs(1);

    for (int i = 0; i <= maxLevel; ++i) {
        cout << leaf[i];
        if (i != maxLevel)
            cout << " ";
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值