PAT (Advanced Level) Practice 1029 Median(25分)【双指针】

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N ( ≤ 2 × 1 0 5 ) N (≤2×10^5) N(2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题意

给定两个有序数组,计算二者合并后的中位数。

思路

两个数组都读下来查找会内存超限,需要一边读第二个数组一边找中位数。而且有可能第二个数组已经读完了但是还没有找到中位数的位置。

代码

#include <iostream>

using namespace std;

long int arr[200005];

int main() {
    cin.tie(nullptr);
    cout.tie(nullptr);
    ios::sync_with_stdio(false);

    int n1, n2, cur1 = 0, cur2 = 0, mid, ans, t;

    cin >> n1;  // 读入第一个数组
    for (int i = 0; i < n1; ++i)
        cin >> arr[i];

    cin >> n2;
    mid = (n1 + n2 + 1) / 2;

    while (cur1 + cur2 < mid and cur2 < n2) {  // 在线处理第二个数组
        cin >> t;  // 注意最多读入n2个数
        while (cur1 < n1 and cur1 + cur2 < mid and arr[cur1] <= t)
            ans = arr[cur1++];
        if (cur1 + ++cur2 <= mid) ans = t;
    }

    while (cur1 + cur2 < mid)  // n2个数全部读入但还是没有到达mid
        ans = arr[cur1++];

    cout << ans;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值