F - Prime Path (bfs)

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0

题目大意:
给出两个四位正整数,改变第一个的树的个位,十位,百位,千位,并且每次只能改变一位数字,改变后的数字只能是素数,知道变为第二个四位数~

注意,不存在前导0~也就是千位不能为0

#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cstdio>
#define MAXN 10
using namespace std;
int v[MAXN][MAXN][MAXN][MAXN];//标记,是否被访问
struct node
{
    int a;//千位
    int b;//百位
    int c;//十位
    int d;//个位
    int step;//步数
}que[12345], q, p;
int A, B, C, D;//要到达的数字
int judge(int a, int b, int c, int d)//判断是否为素数
{
    int t = a*1000 + b*100 + c*10 +d;
        for(int i=2;i*i<=t;i++)
        {
            if(t%i==0)//取余是否为0
                return 0;
        }
        return 1;
}
void bfs(int a, int b, int c, int d)
{
    v[a][b][c][d] = 1;//标记
    int front = 0, rear = 0;
    q.a = a;
    q.b = b;
    q.c = c;
    q.d = d;
    q.step = 0;
    que[rear++] = q;//入队
    while(front<rear)
    {
        p = que[front++];
        if(p.a==A&&p.b==B&&p.c==C&&p.d==D)//判断到达时
        {
            cout<<p.step<<endl;//输出步数
            return ;
        }
        for(int i=1;i<10;i++)//遍历千位的可能,&从1开始
        {
            q = p;
            q.a = i;
            q.step = p.step + 1;
            if(judge(q.a, q.b, q.c, q.d)&&v[q.a][q.b][q.c][q.d]==0)
            {
                v[q.a][q.b][q.c][q.d] = 1;
               que[rear++] = q;
            }
        }
        for(int i=0;i<10;i++)//百位
        {
            q = p;
            q.b = i;
            q.step = p.step + 1;
            if(judge(q.a, q.b, q.c, q.d)&&v[q.a][q.b][q.c][q.d]==0)
            {
                v[q.a][q.b][q.c][q.d] = 1;
               que[rear++] = q;
            }
        }
        for(int i=0;i<10;i++)//十位
        {
            q = p;
            q.c = i;
            q.step = p.step + 1;
            if(judge(q.a, q.b, q.c, q.d)&&v[q.a][q.b][q.c][q.d]==0)
            {
                v[q.a][q.b][q.c][q.d] = 1;
               que[rear++] = q;
            }
        }
        for(int i=0;i<10;i++)//个位
        {
            q = p;
            q.d = i;
            q.step = p.step + 1;
            if(judge(q.a, q.b, q.c, q.d)&&v[q.a][q.b][q.c][q.d]==0)
            {
                v[q.a][q.b][q.c][q.d] = 1;
               que[rear++] = q;
            }
        }

    }
    cout<<"Impossible"<<endl;
}
int main()
{
    int t, a, b;
    cin>>t;//测试组数
    while(t--)
    {
        cin>>a>>b;//两个四位正整数
        memset(v, 0, sizeof(v));//清空
        p.a = a/1000;//取千位
        a = a%1000;
        p.b = a/100;//取百位
        a = a%100;
        p.c = a/10;//取十位
        p.d = a%10;//个位
        A = b/1000;//千位
        b = b%1000;
        B = b/100;//百位
        b = b%100;
        C = b/10;//十位
        D = b%10;//个位
        bfs(p.a, p.b, p.c, p.d);//广搜
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值