Arctic Network(Prim)

Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 22153 Accepted: 6853
Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input

1
2 4
0 100
0 300
0 600
150 750
Sample Output

212.13
Source

Waterloo local 2002.09.28

国防部(DND)要用无线网络连接北部几个哨所。两种不同的通信技术被用于建立网络:
每一个哨所有一个无线电收发器,一些哨所将有一个卫星频道。
任何两个有卫星信道的哨所可以通过卫星进行通信,而不管他们的位置。同时,当两个
哨所之间的距离不超过D时可以通过
无线电通讯,D取决于对收发器的功率。功率越大,D也越大,但成本更高。出于采购
和维修的方便,所有哨所的收发器必
须是相同的;那就是说,D值对每一个哨所相同。

你的任务是确定收发器的D的最小值。每对哨所间至少要有一条通信线路(直接或间接)。

一道令我崩溃的题目~
注意double 的输出格式,%.2f~(%.2lfWrong Answer了一上午……)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <cmath>
using namespace std;
const double INF = 1e12;
double ma[505][505];
struct node//结构体存储坐标
{
    double x, y;
}e[505];
int n, m;
double dist[1209];
int v[1290];
double distancedd(int i, int j)//转化为距离,double类型
{
    double x, y;
    x = e[i].x - e[j].x;
    y = e[i].y - e[j].y;
    return sqrt(x*x+y*y);
}
void Prim(int s)
{
    int i;
    memset(v, 0, sizeof(v));
    for(i=0;i<m;i++)
        dist[i] = ma[s][i];
    v[s] = 1;
    double min;
    int point;
    dist[s] = 0;
    for(i=1;i<m;i++)
    {
        point = s;
        min = INF;
        for(int j=0;j<m;j++)
        {
            if(v[j]==0&&dist[j]<min)
            {
                min = dist[j];
                point = j;
            }
        }
        v[point] = 1;
        for(int j=0;j<m;j++)
        {
            if(ma[point][j]<dist[j]&&v[j]==0)
                dist[j] = ma[point][j];
        }
    }
    sort(dist, dist+m);//排序
    printf("%.2f\n", dist[m-n]);//输出除了卫星连接的剩下的最大值
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        scanf("%d %d", &n, &m);
        for(int i=0;i<m;i++)
        {
            scanf("%lf %lf", &e[i].x, &e[i].y);
        }
        for(int i=0;i<m;i++)//转化距离
        {
            for(int j=0;j<i;j++)
            {
                ma[i][j] = ma[j][i] = distancedd(i, j);
            }
            ma[i][i] = INF;//初始化
        }
        Prim(0);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值