Arctic Network (Kruskal)

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750
Sample Output
212.13

题意:有S颗卫星和P个哨所,有卫星的两个哨所之间可以任意通信;否则,一个哨所只能和距离它小于等于D的哨所通信。

给出卫星的数量和P个哨所的坐标,求D的最小值。

分析:这是一个最小生成树问题。P个哨所最多用P-1条边即可连起来,而S颗卫星可以代替S-1条边,

基于贪心思想,代替的边越长,求得的D就越小。

设现在有的边数是cnt条,总点数是p,卫星数是S 则有 cnt+S-1=p-1;因此最大的一条边是第cnt=p-s条

 代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
#define MAX 505
using namespace std;
double L(int x1,int y1,int x2,int y2);
struct node1{
    int x,y;
};
struct node{
    int u,v;
    double w;
}e[MAX*MAX];
int N;
int s,p;
int pre[MAX];
void init(){   //初始化pre
    int i;
    for(i=0;i<=p;i++)
        pre[i]=i;
}
int Find(int x){   
    int r=x;
    while(r!=pre[r])  //寻找根节点
        r=pre[r];
    int i=x,j;
    while(i!=r){    //压缩路径
        j=pre[i];
        pre[i]=r;
        i=j;
    }
    return r;
}
int mix(int a,int b){   //判断这条边是否已经加入
    int fa=Find(a),fb=Find(b);
    if(fa!=fb){
        pre[fb]=fa;
        return 1;
    }
    return 0;
}
int cmp(node a,node b){
    return a.w<b.w;
}
int main(){
    scanf("%d",&N);
    while(N--){
        scanf("%d%d",&s,&p);
        node1 num[MAX];
        int i,j;
        int t=0;
        for(i=1;i<=p;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            num[i].x=a;
            num[i].y=b;
            for(j=1;j<i;j++){//存入边关系
                double s=L(a,b,num[j].x,num[j].y);  
                e[t].u=i;
                e[t].v=j;
                e[t++].w=s;
               // printf("---%.3f--\n",e[t-1].w);
            }
        }
        sort(e,e+t,cmp); //按从小到大排序
        init();
        int cnt=0;
        double sum=0;
        for(i=0;i<t;i++){   
            if(mix(e[i].u,e[i].v)){
                if(cnt<p-s)  //找到除去卫星可代替的边的最大一条
                sum=e[i].w;
                cnt++;
            }
            if(cnt==p-1) break; //当加入到边比点数少一时,形成树
        }
        printf("%.2f\n",sum);
    }
return 0;
}
double L(int x1,int y1,int x2,int y2){   //求两点间距离
    double x=(x1-x2)*(x1-x2)*1.0;
    double y=(y1-y2)*(y1-y2)*1.0;
    return sqrt(x+y);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值