Balanced Lineup(线段树+最大值,最小值)

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 56970 Accepted: 26694
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output
Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
int maxn[209876];
int minn[209876];
int ma[209876];
void PushUp(int node)//单点更新
{
  maxn[node] = max(maxn[node*2], maxn[node*2+1]);
  minn[node] = min(minn[node*2], minn[node*2+1]);
  return ;
}
void Build(int node, int l, int r)//建树
{
   if(l==r)
   {
     scanf("%d", &ma[node]);
     maxn[node] = ma[node];
     minn[node] = ma[node];
     return ;
   }
   int m = (l + r) / 2;
   Build(node * 2, l, m);
   Build(node * 2 + 1, m+1, r);
   PushUp(node);
}
int ka(int node, int l, int r, int left, int right)//寻找区间最大值
{
   if(left<=l&&r<=right)
   {
     return maxn[node];
   }
   int m = (l + r) / 2;
   int res = 0;
   if(left<=m)
   res = max(res, ka(node * 2, l, m, left, right));
   if(m<right)
   res = max(res, ka(node * 2 + 1, m+1, r, left, right));
   return res;
}
int ki(int node, int l, int r, int left, int right)//寻找区间最小值
{
   if(left<=l&&r<=right)
   {
     return minn[node];
   }
   int m = (l + r) / 2;
   int res = 0x3f3f3f3f;
   if(left<=m)
   res = min(res, ki(node * 2, l, m, left, right));
   if(m<right)
   res = min(res, ki(node * 2 + 1, m+1, r, left, right));
   return res;
}
int main()
{
   int n, m;
   while(~scanf("%d %d", &n, &m))
   {
   Build(1, 1, n);
   while(m--)
   {
     int a, b;
     scanf("%d %d", &a, &b);
     printf("%d\n", ka(1, 1, n, a, b) - ki(1, 1, n, a, b));
   }
   }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值