线段树,最大最小值





http://poj.org/problem?id=3264


Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 33762 Accepted: 15872
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

线段树,

题目是要找出区间最大最小值。




#include <stdio.h>
#include <stdlib.h>
#include <numeric>
#include <iostream>
using namespace std;
#define my_min 99999999
#define my_max -99999999
struct node//线段树节点
{
	int l,r;
	int nmin,nmax;
	node *pleft,*pright;
};
int nmax,nmin;
node tree[1000000];
int count=0;
void buildtree(node *proot,int l,int r)
{
	proot->l=l;
	proot->r=r;
	proot->nmin=my_min;
	proot->nmax=my_max;
	if(l!=r)
	{
		count++;//左节点,在数组中间的位置
		proot->pleft=tree+count;
		count++;//右节点
		proot->pright=tree+count;
		buildtree(proot->pleft,l,(l+r)/2);
		buildtree(proot->pright,(l+r)/2+1,r);
	}
}
void insert(node *proot,int i,int v)
{
	if(proot->l==i&&proot->r==i)
		//到达叶子节点的区间元素
	{
		proot->nmin=proot->nmax=v;
		//叶子节点最大最小值相等
		return ;
	}
	proot->nmin=min(proot->nmin,v);
	proot->nmax=max(proot->nmax,v);
	if(i<=(proot->l+proot->r)/2)//叶子节点在左子树
	{
		insert(proot->pleft,i,v);
	}
	else
	{
		insert(proot->pright,i,v);//叶子节点在右子树
	}
}
void query(node *proot,int s ,int e)
{
	if(proot->nmin>=nmin&&proot->nmax<=nmax)
		//剪枝函数 如果超出区间最大最小值,直接返回
	{
		return;
	}
	if(s==proot->l&&e==proot->r)
		//恰好找到对应区间,则调整最大最小直接返回
	{
		nmin=min(proot->nmin,nmin);
		nmax=max(proot->nmax,nmax);
		return;
	}
	if(e<=(proot->l+proot->r)/2)
	{
		//查找区间在左子树
		query(proot->pleft,s,e);
	}
	else if(s>=(proot->l+proot->r)/2+1)
	{
		//查找区间在右子树
		query(proot->pright,s,e);
	}
	else
	{
		//查找区分被分割,则调整查找区间,再分别找左右数
		query(proot->pleft,s,(proot->l+proot->r)/2);
		query(proot->pright,(proot->l+proot->r)/2+1,e);
	}
}
int main()
{
	int n,m,h;
	cin>>n>>m;
	count=0;
	buildtree(tree,1,n);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&h);
		insert(tree,i,h);
	}
	for(int i=0;i<m;i++)
	{
		int s,e;
		scanf("%d%d",&s,&e);
		nmax=my_max;
		nmin=my_min;
		query(tree,s,e);
		printf("%d\n",nmax-nmin);
	}
	return 0;
}

















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值