1007. Maximum Subsequence Sum (25)

  1. Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

#include <bits/stdc++.h>
using namespace std;
int a[12345];
int main()
{
  int n;
  cin>>n;
  for(int i=0;i<n;i++)
  {
    scanf("%d", &a[i]);
  }
  int sum = 0;
  int Start = 0, End = 0;
  int maxn = -1;
  int s = 0;
  for(int i=0;i<n;i++)
  {
    sum += a[i];
    if(sum>maxn)
    {
      maxn = sum;
      Start = s;
      End = i;
    }
    else if(sum<0)
    {
      sum = 0;
      s = i + 1;
    }
  }
   int flag = 0;
  for(int i=0;i<n;i++)
  {
    if(a[i]>=0)
    {
      flag = 1;
      break;
    }
  }
  if(flag)
  printf("%d %d %d\n", maxn, a[Start], a[End]);
  else
  printf("%d %d %d\n", 0, a[0], a[n-1]);
  return 0;
  }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值