01-复杂度2 Maximum Subsequence Sum (25分) (C语言)

Given a sequence of K integers { N1, N2, …, NK}. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:
10 1 4

作者: 陈越
单位: 浙江大学
时间限制: 200 ms
内存限制: 64 MB
谷歌翻译:
给定一个K个整数序列{N1, N2,…,NK}。连续子序列定义为{Ni, Ni+1,…,其中1≤i≤j≤K。最大子序列是元素和最大的连续子序列。例如,给定序列{-2,11,-4,13,-5,-2},其最大子序列为{11,-4,13},其最大和为20。
现在你需要找到最大子序列的最大和,以及最大子序列的第一个和最后一个数字。
输入规格:
每个输入文件包含一个测试用例。每种情况占用两行。第一行包含一个正整数K(≤10000)。第二行包含K个数字,用空格隔开。
输出规范:
对于每个测试用例,在一行中输出最大的和,以及最大子序列的第一个和最后一个数字。数字之间必须用一个空格隔开,但行尾必须没有多余的空格。如果最大子序列不是惟一的,则输出索引i和j最小的子序列(如示例所示)。如果所有的K个数都是负数,那么它的最大值和定义为0,你应该输出整个序列的第一个和最后一个数。
样例输入:
10
-10 1 23 4 -5 -23 3 7 -21

样例输出:
10 1 4

解析:题目比较简单,主要是确定左下标和右下标
AC代码如下:

#include <stdio.h>
#include <stdlib.h>
int main() {
    int a[10000];
    int k, i, left, isright, isleft, NowSum = 0, MaxSum = -10000;
    scanf("%d", &k);
    for (i = 0; i < k; i++) {
        scanf("%d", &a[i]);
    }
 //用在线处理算法 
    for (i = 0; i < k; i++) {
        NowSum += a[i];
        if (NowSum < 0) {
            NowSum = 0;
            left = i + 1; //临时的序列最左边项

        } else if (NowSum > MaxSum) {
            MaxSum = NowSum;
            isright = i;  //序列最右边,如果最新的NowSum大于原来的MaxSum,就改变isright的值
            isleft = left; //最终的序列最左边
        }
    }
    if (MaxSum < 0)
        printf("0 %d %d\n", a[0], a[k - 1]); //全部序列为0时
    else
        printf("%d %d %d\n", MaxSum, a[isleft], a[isright]);

    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值