Maximum GCD

Maximum GCD
Given the N integers, you have to find the maximum GCD (greatest common divisor) of every possible
pair of these integers.
Input
The first line of input is an integer N (1 < N < 100) that determines the number of test cases.
The following N lines are the N test cases. Each test case contains M (1 < M < 100) positive
integers that you have to find the maximum of GCD.
Output
For each test case show the maximum GCD of every possible pair.
Sample Input
3
10 20 30 40
7 5 12
125 15 25
Sample Output
20
1
25

是一道水题,但是注意读入,可能会有多余的空格。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>
using namespace std;
int gcd(int a, int b)
{
    return b==0?a:gcd(b, a%b);
}
int main()
{
    int n;
    scanf("%d", &n);
    getchar();
    while(n--)
    {
        char ma[21311];
        gets(ma);
        int top = -1;
        int k[12311];
        int ans = 0;
        int len = strlen(ma);
        int f = 0;
        for(int i=0;i<len;i++)
        {
            if(ma[i]!=' ')
            {
                f = 1;
                ans = ans * 10 + ma[i] - '0';
            }
            else
            {
                k[++top] = ans;
                f = 0;
                ans = 0;
            }
        }
        if(f==1)
        k[++top] = ans;
        int maxn = 0;
        for(int i=0;i<=top;i++)
        {
            for(int j=i+1;j<=top;j++)
            {
                maxn = max(maxn, gcd(k[i], k[j]));
            }
        }
        printf("%d\n", maxn);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值