Galactic Collegiate Programming Contest(结构体运算符重载,set)

Galactic Collegiate Programming Contest
Problem ID: gcpc
Time limit: 6 seconds
Picture by GuillaumePreat on Pixabay, cc0
One hundred years from now, in 2117, the International
Collegiate Programming Contest
(of which the NCPC is a part) has expanded
significantly and it is now the Galactic Collegiate
Programming Contest (GCPC).
This year there are n teams in the contest.
The teams are numbered 1, 2, … , n, and your
favorite team has number 1.
Like today, the score of a team is a pair of
integers (a, b) where a is the number of solved
problems and b is the total penalty of that team.
When a team solves a problem there is some associated penalty (not necessarily calculated in
the same way as in the NCPC – the precise details are not important in this problem). The total
penalty of a team is the sum of the penalties for the solved problems of the team.
Consider two teams t1 and t2 whose scores are (a1, b1) and (a2, b2). The score of team t1 is
better than that of t2 if either a1 > a2, or if a1 = a2 and b1 < b2. The rank of a team is k + 1
where k is the number of teams whose score is better.
You would like to follow the performance of your favorite team. Unfortunately, the organizers
of GCPC do not provide a scoreboard. Instead, they send a message immediately whenever a
team solves a problem.
Input
The first line of input contains two integers n and m, where 1 ≤ n ≤ 105
is the number of teams,
and 1 ≤ m ≤ 105
is the number of events.
Then follow m lines that describe the events. Each line contains two integers t and p
(1 ≤ t ≤ n and 1 ≤ p ≤ 1000), meaning that team t has solved a problem with penalty p. The
events are ordered by the time when they happen.
Output
Output m lines. On the i’th line, output the rank of your favorite team after the first i events
have happened.
Sample Input 1 Sample Output 1
3 4
2 7
3 5
1 6
1 9
2
3
2
1
题目大意:
给出n个队伍,m次提交ac,每次有队伍名和罚时,问一号队伍排在第几名。注意:1, 2, 2, 2, 5也就是说,有队伍和题数和罚时一样的情况下,看id号。

思路:
用set存储排在1之前的队伍id,然后每次更新,如果是1队,则遍历一遍set,删除排在其之后的,如果是其他队伍,更新之后大于一队,直接insert队伍的id(set,不存在重复元素)

一:set < int >

#include <bits/stdc++.h>
using namespace std;
struct node
{
    int id;
    int t;
    int p;
    bool operator <(const node &a)const
    {
        if(t==a.t)
        {
            if(p==a.p)
            {
                return id>a.id;
            }
            else
            return p>a.p;
        }
        else
        return t<a.t;
    }
} w[123123];
set<int>q;
int main()
{
    int n, m;
    scanf("%d %d", &n, &m);
    q.clear();
    for(int i=0; i<=n; i++)
    {
        w[i].p = 0;
        w[i].t = 0;
        w[i].id = i;
    }
    for(int i=0; i<m; i++)
    {
        int t, p;
        scanf("%d %d", &t, &p);
        w[t].t++;
        w[t].p+=p;
        if(t!=1)
        {
            if(w[1]<w[t])
            {
                q.insert(t);
            }
            cout<<q.size()+1<<endl;
        }
        else
        {
            set<int>::iterator it;
            for(it = q.begin();it!=q.end();)
            {
                if(w[*it]<w[1])
                {
                    q.erase(it++);
                }
                else
                    ++it;
            }
            cout<<q.size()+1<<endl;
        }
    }
    return 0;
}

二:set < node >

#include <bits/stdc++.h>
using namespace std;
struct node
{
    int id;
    int t;
    int p;
    bool operator == (const node &a)const
    {
        return id==a.id&&t==a.t&&p==a.p;
    }
    bool operator <(const node &a)const
    {
        if(t==a.t)
        {
            if(p==a.p)
                return id>a.id;
            else
                return p>a.p;
        }
        else
            return t<a.t;
    }
} w[123123];
set<node>q;
int main()
{
    int n, m;
    scanf("%d %d", &n, &m);
    q.clear();
    for(int i=0; i<=n; i++)
    {
        w[i].p = 0;
        w[i].t = 0;
        w[i].id = i;
    }
    for(int i=0; i<m; i++)
    {
        int t, p;
        scanf("%d %d", &t, &p);
        set<node>::iterator it;
        if(t!=1)
        {
            if(q.find(w[t])!=q.end())
                q.erase(w[t]);
            w[t].t++;
            w[t].p+=p;
            if(w[1]<w[t])
                q.insert(w[t]);
            cout<<q.size()+1<<endl;
        }
        else
        {
              w[t].t++;
              w[t].p+=p;
              for(it=q.begin();it!=q.end();)
              {
                  if(*it<w[1])
                    q.erase(it++);
                  else
                    ++it;
              }
              cout<<q.size()+1<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值