1023 Have Fun with Numbers (20 分)
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.
Sample Input:
1234567899
Sample Output:
Yes
2469135798
大体意思是:
哦,瞧瞧这百度翻译多么的可爱。
代码如下:
#include<stdio.h>
#include<string.h>
char s1[22];
char s2[22];
int a[10];
int main()
{
scanf("%s\n", s1);//以字符串形式输入题给数字
int i;
int j =0;
int x = 0;
int carry = 0;
for(i = strlen(s1)-1;i >= 0; i--)
{
x = s1[i] - '0';
a[x]++;//把出现的每个数字记录
x = x*2 + carry;
s2[i] = x%10 + '0';
a[x%10]--;
carry = x/10;
}
if(carry != 0 )
{
a[carry]--;
}
int flag = 0;
for(i = 0; i< 10; i++)
{
if(a[i] != 0)
{
flag = 1;
break;
}
}
if(flag)
{
printf("No\n");
}
else
{
printf("Yes\n");
}
if(carry != 0 )
{
printf("%d",carry);
}
for(i = 0 ; i < strlen(s2); i++)
{
printf("%c",s2[i]);
}
printf("\n");
return 0;
}