HDU 2444 The Accomodation of Students(判断是否为二分图+最大匹配)

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4084    Accepted Submission(s): 1872


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
  
  
No 3
 

Source
 

题意:

        n个学生,有m对人是认识的,每一对认识的人能分到一间房,问能否把n个学生分成两部分,每部分内的学生互不认识,而两部分之间的学生认识。如果可以分成两部分,就算出房间最多需要多少间,否则就输出No

分析:

先是要判断是否为二部图,然后求最大匹配。


/*
    hdu 2444
    题意:判断是否是二分图,并输出最大匹配数
 
    YY:用'临点填色法'判断,相邻点异色,发现同色则不成立
        然后匈牙利算法, 求出个数除2
 
    注:匈牙利算法时间复杂度 '邻接表': O(mn),邻接矩阵: O(n^3)
*/
 
 
#include <stdio.h>
#include <string.h>
 
bool map[210][210];//连接图
bool visit[210];//判断是否访问过
int link[210];// 当前链接表
int judge[210];// 判断二分图时 0-1表
 
int queue[210];
int n,m;
 
bool BFS()
{ //二分图BFS判断
    int v,start = 0,end = 1;
    queue[0] = 1; 
    for(int i=0;i<=n;i++) 
        judge[i] = -1;
    v = queue[start];
    judge[1] = 0;
    memset(visit,0,sizeof(visit));
 
    while(start<end)
    {
        v= queue[start];
        for(int i = 1;i <= n; i++)
        {
            if(map[v][i]){
                if(judge[i] == -1){
                    judge[i] = (judge[v]+1)%2;
                    queue[end++] = i;   
                }
                else{
                    if(judge[i] == judge[v])
                        return false;           
                }
            }
        }
        start++;
    }
    return true;
}
 
int can(int r)
{
    for(int i=1;i<=n;i++)
    {
        if(map[r][i] && visit[i] == 0){
            visit[i] = 1;
            if(link[i]==0 || can(link[i])){
                link[i] = r;
                return 1;
            }
        }
    }
    return 0;
}
 
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(map,0,sizeof(map));
        int a,b;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            map[a][b] = 1;
            map[b][a] = 1;
        }
 
        //judge the bipartite graph
 
        if(!BFS()) {
            printf("No\n");continue;
        }
 
        //the maximum number of pair
        int num = 0;
        memset(link,0,sizeof(link));
        for(int i=1;i<=n;i++)
        {
            memset(visit,0,sizeof(visit));          
            if(can(i)) num++;
        }
        printf("%d\n",num/2);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值