hdu 2444 The Accomodation of Students —— 判断是否为二分图 + 二分图匹配

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input

For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.
 

Output

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.

Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output

No
3

思路:

题大意就是给出几个学生,给出两两认识的学生,然后判断是否能分成两组互相不认识的(判断是否为二分图),如果能,那么问能最多有几组两两认识的学生(二分图最大匹配)

判断二分图这里用染色法,遍历这个图,对图用两个颜色进行染色,要求临节点颜色不同,如果染色过程中出现临节点颜色相同情况,那么就不是二分图,如果染色成功,那么是二分图。

判断二分图后,求二分图最大匹配即可。

 

AC代码:

#include<cstdio>
#include<iostream>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cmath>
#include<cstring>

#define MAXN 205

using namespace std;

int n, m;
bool edge[MAXN][MAXN], vis[MAXN];
int match[MAXN];

bool bfs(int x){
    int color[MAXN] = {0};
    queue<int> que;
    color[x] = 1;
    que.push(x);
    while(!que.empty()){
        int head = que.front();
        for(int i = 1; i <= n; i++){
            if(edge[head][i] == true){
                if(color[i] == 0){
                    color[i] = -color[head];
                    que.push(i);
                }
                else if(color[i] == color[head]){
                    return false;
                }
            }
        }
        que.pop();
    }
    return true;
}

bool dfs(int u){
    for(int i = 1; i <= n; i++){
        if(vis[i] == false && edge[u][i] == true){
            vis[i] = true;
            if(match[i] == 0 || dfs(match[i])){
                match[i] = u;
                return true;
            }
        }
    }
    return false;
}

int main(){
    while(scanf("%d%d", &n, &m) != EOF){
        memset(edge, false, sizeof(edge));
        memset(match, 0, sizeof(match));
        for(int i = 1; i <= m; i++){
            int t1, t2;
            scanf("%d%d", &t1, &t2);
            edge[t1][t2] = true;
        }
        if(!bfs(1)){
            printf("No\n");
        }
        else{
            int sum = 0;
            for(int i = 1; i <= n; i++){
                memset(vis, false, sizeof(vis));
                if(dfs(i)){
                    sum++;
                }
            }
            printf("%d\n", sum);
        }
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值