HDU 3926 Hand in Hand(判断同构)

Hand in Hand

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 122768/62768 K (Java/Others)
Total Submission(s): 1880    Accepted Submission(s): 635


Problem Description
In order to get rid of Conan, Kaitou KID disguises himself as a teacher in the kindergarten. He knows kids love games and works out a new game called "hand in hand".

Initially kids run on the playground randomly. When Kid says "stop", kids catch others' hands immediately. One hand can catch any other hand randomly. It's weird to have more than two hands get together so one hand grabs at most one other hand. After kids stop moving they form a graph.

Everybody takes a look at the graph and repeat the above steps again to form another graph. Now Kid has a question for his kids: "Are the two graph isomorphism?"
 

Input
The first line contains a single positive integer T( T <= 100 ), indicating the number of datasets.
There are two graphs in each case, for each graph:
first line contains N( 1 <= N <= 10^4 ) and M indicating the number of kids and connections.
the next M lines each have two integers u and v indicating kid u and v are "hand in hand".
You can assume each kid only has two hands.
 

Output
For each test case: output the case number as shown and "YES" if the two graph are isomorphism or "NO" otherwise.
 

Sample Input
  
  
2 3 2 1 2 2 3 3 2 3 2 2 1 3 3 1 2 2 3 3 1 3 1 1 2
 

Sample Output
  
  
Case #1: YES Case #2: NO
 

Source

因为每个人小朋友只有两只手,所以每个点最多只有2度。图有可能是环、链,以及环和链构成的复杂图。  

  如何判断两幅图是否相似呢?判断相似是判断两幅图的圈的数量,以及构成圈的点数是否相同。还有判断链的数目和构成链的点数是否相同。

  具体实现:标记环(或者链),按照点的数目排序。如果点数相同,环排在前面。然后逐个判断,如果全部都相同,就是同构。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=10010;
struct node
{
    int cnt;
    bool iscc;
}arr1[N],arr2[N];
int f[N],r[N],iscir[N];
bool cmp(const node &x, const node &y)
{
    if(x.cnt!=y.cnt) return x.cnt<y.cnt;
    if(x.iscc<y.iscc) return 1;
    return 0;
}
int Find(int x)
{
    if(x==f[x]) return x;
    return f[x]=Find(f[x]);
}
void Link(int i,int j)
{
    int a=Find(i),b=Find(j);
    if(a!=b) {f[b]=a;r[a]+=r[b];}
    else iscir[a]=1;
}
void init()
{
    for(int i=0;i<N;i++)
    {
        f[i]=i;iscir[i]=0;r[i]=1;
    }
}
int main()
{
    //freopen("test.txt","r",stdin);
    int ca,k,i,j,x,y,n1,m2,n2,m1,a,b;
    k=1;
    scanf("%d",&ca);
    while(ca--)
    {
        scanf("%d%d",&n1,&m1);
        init();
        while(m1--)
        {
            scanf("%d%d",&x,&y);
            Link(x,y);
        }
        a=0;
        for(i=1;i<=n1;i++)
        {
            if(i==Find(i))
            {
                arr1[a].cnt=r[i];
                arr1[a++].iscc=iscir[i];
            }
        }
        scanf("%d%d",&n2,&m2);
        init();
        while(m2--)
        {
            scanf("%d%d",&x,&y);
            Link(x,y);
        }
        b=0;
        for(i=1;i<=n1;i++)
        {
            if(i==Find(i))
            {
                arr2[b].cnt=r[i];
                arr2[b++].iscc=iscir[i];
            }
        }
        printf("Case #%d: ",k++);
        if(n2!=n1||m2!=m1)
        {
            printf("NO\n");
            continue;
        }
        if(a==b)
        {
            sort(arr1,arr1+a,cmp);
            sort(arr2,arr2+a,cmp);
            for(i=0;i<a;i++)
            {
                if(arr1[i].cnt!=arr2[i].cnt) break;
                if(arr1[i].iscc!=arr2[i].iscc) break;
            }
            if(i==a) printf("YES\n");
            else printf("NO\n");
        }
        else printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值