Cube Stacking

Cube Stacking

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

题目解析:

本题讲的是有n件物品,和几个操作,M代表把a所在的堆全部放到b的上方,C代表查询a上方有几个物品。原来想的模拟栈,不过一看数据我就放弃了。后来想了想,果断并查集,而且还是带权的那种。
我们需要定义两个数组,一个dis[]表示当前物品上面有多少物品,一个cnt[]表示当前物品所在的堆的物品个数,然后就是带权并查集套路。

代码如下:

  #include <iostream>  
    #include <cstdio>  
    using namespace std;  

    const int maxn=31000;  
    int father[maxn],cnt[maxn],dis[maxn];  

    int find(int x){  
        if(father[x]!=x){  
            int tmp=father[x];  
            father[x]=find(father[x]);  
            dis[x]+=dis[tmp];  
        }  
        return father[x];  
    }  

    void combine(int x,int y){  
        father[x]=y;  
        dis[x]+=cnt[y];  
        cnt[y]+=cnt[x];  
    }  

    int main(){  
        int m;  
        scanf("%d",&m);  
        for(int i=0;i<maxn;i++){  
            father[i]=i;  
            cnt[i]=1;  
            dis[i]=0;  
        }  
        while(m-- >0){  
            char ch;  
            cin>>ch;  
            if(ch=='M'){  
                int a,b;  
                scanf("%d%d",&a,&b);  
                if(find(a)!=find(b)) combine(find(a),find(b));  
            }else{  
                int x;  
                scanf("%d",&x);  
                find(x);  
                printf("%d\n",dis[x]);  
            }  
        }  
        return 0;  
    }  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值