Tree Cutting(树的重心)

Tree Cutting

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.

Please help Bessie determine all of the barns that would be suitable to disconnect. 

Input

* Line 1: A single integer, N. The barns are numbered 1..N.

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y. 

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE". 

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

题目大意:

以每个节点为根,统计出每个节点的最大子树节点个数,找出小于等于n/2的所有节点。

题目解析:

运用找树的重心的方法,统计出每个节点的最大子树的节点个数,判断一下就行。

代码如下:

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn = 10000 + 5;

struct Edge{
    int next,to;
}G[maxn << 1];

int n,head[maxn],cnt;
int f[maxn],dp[maxn];

void Insert(int u,int v){
    G[++cnt].next = head[u];
    G[cnt].to = v;
    head[u] = cnt;
}

void dfs(int u,int fa){
    f[u] = 1;
    int maxd = 0;
    for(int e = head[u];e;e = G[e].next){
        int v = G[e].to;
        if(v == fa)continue;
        dfs(v,u);
        f[u] += f[v];
        maxd = max(maxd,f[v]);
    }
    dp[u] = max(maxd,n - f[u]);
}

void init(){
    for(int i = 0;i < maxn; i++){
        dp[i] = 0;
        head[i] = 0;
        f[i] = 0;
    }
    cnt = 0;
}

int main(){
    int u,v;
    while(~scanf("%d",&n) && n){
        init();
        for(int i = 0;i < n-1; i++){
            scanf("%d%d",&u,&v);
            Insert(u,v);
            Insert(v,u);
        }
        dfs(1,-1);
        int ans = 0;
        for(int i = 1;i <= n; i++){
            if(dp[i] <= n/2){
                printf("%d\n",i);
            }
        }
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值