Randomized Fibonacci

概率论
题目:Consider the following way to generate a new “randomized” fibonacci sequence.

a0 = 1, ai = aj + ak, i > 0, j and k are picked randomly from all integers in the interval [0, i-1] (j and k are independent).

Now given n, among all the posibilities of the final sequence of length n, what is the expectation of an?

Input
One line with an integer n.

Output
One line with an float number representing the answer. The answer will be considered right if it has a relative or absolute error which is less than 10-6 to the standard answer.

Sample Input
2
Sample Output
3.000000
题意:随机斐波那契数列
a0 = 1, a1 = 1, ai = ai-1 + ai-2,(i > 1)。 现在考虑如下生成的斐波那契数列: a0 = 1, ai = aj + ak, i > 0, j, k从[0, i-1]的整数中随机选出(j和k独立)。 现在给定n,要求求出E(an),即各种可能的a数列中an的期望值。
暴力或者好用的结论:n+1

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<sstream>
#include<iostream>
#include<cmath>
#include<queue>
#include<map>
#include<set>
#include<iomanip>
#define ll long long
using namespace std;
int main()
{
    int n,d,t;
    double s1;
    scanf("%lf",&s1);
    printf("%.6lf\n",s1+1);
	
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值