杭电oj 1004

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

问哪个颜色出现的次数最多
输入0表示结束
字符串比较

#include <stdio.h>
#include <string.h>
int main(void) {
    int n;
    while(scanf("%d", &n) && n) {    //如果n为0结束循环
        int max = 0, x= 0, b[1000] = {0};
        char a[1000][16];
        for(int i = 0;i < n;i++)
            scanf("%s", &a[i]);
        for(int i = 0;i < n;i++) {
            for(int j = i + 1;j < n;j++)    //直接暴力比较,相同就+1,最后输出出现次数最多的那个颜色
                if(strcmp(a[i],a[j]) == 0)
                    b[i]++;
            if(b[i] > max) {
                max = b[i];
                x = i;
            }
        }
        printf("%s\n", a[x]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值