ZOJ 1100 Mondriaan's Dream

转载自: http://blog.csdn.net/yan_____/article/details/8719748


Mondriaan's Dream

Time Limit: 10 Seconds       Memory Limit: 32768 KB

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input Specification

The input file contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output Specification

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205




稍微改了一下代码


#include <iostream>  
#include <string>
#include <cstring>
using namespace std;

int st[15000][2];  
long long dp[13][5000]; //2^11=2048最多的状态数  
int cnt, h, w;  

void dfs(int n,int from,int to){ //枚举所有一行摆放的可能和其匹配的下层 
    if(n > w)  
        return;  
    if(n == w){ //这一行刚好摆完,得到一行摆放的组合 
        st[cnt][0]=from;  
        st[cnt++][1]=to;
        return;  
    }  
    dfs(n+2,(from<<2)+3,(to<<2)+3); //横着放,这层和下一层匹配的都多两位1  
    dfs(n+1,(from<<1)+1,to<<1);//竖着放,这层多一个1,匹配下层这个位置是0  
    dfs(n+1,from<<1,(to<<1)+1);//不放,这层多一个0,匹配的下层多个1  
}

int main(){  
    int i, j;
    while(cin>>h>>w){
        if(h == 0 || w == 0)
            break;
        if((w * h) % 2){
            cout<<0<<endl;  
            continue;
        }
        memset(dp, 0, sizeof(dp));  
        memset(st, 0, sizeof(st));  
        cnt = 0; //记录每一行摆放所有可能的状态总数  
        dfs(0, 0, 0);  
        dp[0][(1<<w)-1] = 1;//边界  
        for(i = 1; i <= h; i++){
            for(j = 0; j < cnt; j++){  
                dp[i][st[j][1]] += dp[i-1][st[j][0]];  
            }
        }
        cout<<dp[h][(1<<w)-1]<<endl;
    }
    return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值