pku2253 记录从初始到终点最小的路径(某一部分),迪杰斯特拉求最短路


  
  
C - Heavy Transportation
Time Limit:3000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

Background  Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.  Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.  Problem  You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define inf 0xffffff
#define MAX 0x7fffffff
#include<iostream>
using namespace std;
#define MIN -0x7fffffff
__int64 mp[1222][1222];
__int64 dis[1222];
int visit[1222];

int n,m;
void suan()
{
    memset(visit,0,sizeof(visit)); visit[1]=1;
    for(int i=2; i<=n; ++i)
        dis[i]=MIN;
    dis[1]=MAX;


    int pos=1;
    for(int i=1; i<=n; i++)
    {
int mincost=0;
        for(int z=1; z<=n; ++z)
        {
            if(!visit[z]&&mincost<dis[z])
            {
                mincost=dis[z];
                pos=z;
            }
        }
        visit[pos]=1;

        for(int  j=1; j<=n; j++)
        {
            if(mp[pos][j]!=MAX)
            {
                dis[j]=max(dis[j],min(dis[pos],mp[pos][j]));

            }
        }

    }

}
int   main()
{
    int  test;

    scanf("%d",&test);
    for(int ii=1; ii<=test; ii++)
    {
        scanf("%d%d",&n,&m);
        for(int  i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                 mp[i][j]=mp[j][i]=MAX;
            }
        }
        int a,b,c;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&c);

            mp[a][b]=mp[b][a]=c;

        }
        suan();
        printf("Scenario #%d:\n",ii);
        printf("%I64d\n\n",dis[n]);
    }

}
BNUOJ 20950



CUITCPC是一个专门生产大型货运火车的工厂。他们的新型货运火车XX V1.0,是如此之大,以至于可以运输的货物的重量并不取决于那个火车本身,而只是受限于你所通过的铁路的承重。

给你出发和目标城市,你的任务就是求出火车从初始城市到目标城市的最大载重。

输入可能包括一组或者多组测试数据。每一个测试数据的前两行是两个整数:城市的数量n(2<=n<=1000)和铁路的条数r(1<=r<= 19900)。

紧接着是r行,每一行描述一条连接两个城市的铁路以及这段铁路所能承受的最大重量。城市名不会超过30个字符,也不会有空白字符出现在城市名中。承重是一个0-10000的整数。铁路都是双向的。

最后一行是两个城市的名字:初始城市和目标城市。

输入的结束条件是n和r都为0

对于每一组测试数据

输出包括3行:

l  一行输出"Scenario #x",其中x是测试数据的组数

l  一行输出"y tons",其中y表示最大载重量

l  一个空行

4 3
ACM ICPC 100
ICPC World 80
World CPC 120
ACM CPC
5 5
ACM ICPC 100
ICPC World 80
World CPC 120
ACM Chengdu 220
Chengdu CPC 170
CPC ACM
0 0
Scenario #1
80 tons

Scenario #2
170 tons


照抄上面;:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define MAX 0xffffff
#define MIN -0xffffff


#include<iostream>
using namespace std;


#include<map>
int mp[1222][1222];
int dis[1222];
int visit[1222];


int start;
int jiesu;
int n,m;
int suan()
{


    memset(visit,0,sizeof(visit));
    for(int i=0; i<=n; i++)
        dis[i]=MIN;
    dis[start]=MAX;
    int pos=1;








    for(int i=1; i<n; i++)
    {
        int mincost=0;
        for(int z=1; z<=n; z++)
        {
            if(!visit[z]&&mincost<dis[z])
            {
                mincost=dis[z];
                pos=z;
            }
        }


        visit[pos]=1;




        for(int  j=1; j<=n; j++)
        {
            if(mp[pos][j]!=MAX)
            {
                dis[j]=max(dis[j],min(dis[pos],mp[pos][j]));


            }
        }


    }
    return dis[jiesu];




}
int   main()
{
    int sb=1;


    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
            break;


        map<string,int>q;
        for(int  i=0; i<=n; i++)
        {
            for(int j=0; j<=n; j++)
            {
                mp[i][j]=mp[j][i]=MAX;
            }
        }
        string str1,str2;
        int c;
        int count=1;
        while(m--)
        {
            cin>>str1>>str2>>c;


            if(q.find(str1)==q.end())
            {
                q[str1]=count++;
            }
            if(q.find(str2)==q.end())
            {
                q[str2]=count++;
            }




            mp[q[str1]][q[str2]]= mp[q[str2]][q[str1]]=c;


        }
        cin>>str1>>str2;
        start=q[str1];
        jiesu=q[str2];
//        for(int i=1;i<=5;i++)
//            {for(int j=1;j<=5;j++)
//        {
//            printf("%010d ",mp[i][j]);
//        }
//        printf("\n");
//
//
//        }
//        cout<<mp[1][5]<<"   "<<mp[5][1]<<jiesul;
//        cout<<mp[5][4]<<"   "<<mp[4][5]<<jiesul;
//        cout<<mp[4][3]<<"   "<<mp[3][4]<<jiesul;
//        cout<<mp[3][2]<<"   "<<mp[2][3]<<jiesul;
//        cout<<mp[2][1]<<"   "<<mp[1][2]<<jiesul;
//        cout<<start<<"dasd"<<jiesu<<jiesul;
        suan();
        printf("Scenario #%d\n",sb++);
        printf("%d tons\n\n",suan());
    }




}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值