poj 2356(鸽巢原理)

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3


思路

题目大意为给定n个正数,请你从中找出若干个数,使其和刚好是n的倍数。

实际上n个数  并且求n的倍数 条件比较特殊  并且只需要输出一组满足的数即可

可以这样想 modN 只有0~N-1种余数,我计算前i个数的和并计算modN,如果==0那直接输出这i个数即可

如果!=0则将其放在pos[]数组中,余数作为下标,i作为值。当有下一个前j个数的和modN等于前面那个余数时,它也找到了pos[]的相同位置,那么从i+1到j的数的和一定就是N的倍数了,输出得到结果。


下面证明一定有两个sumod[]相等或=0

 若sumod[]==0 直接输出

若不为零 还有1~n-1    n-1种可能

而一个数modN   有n种可能  由鸽巢原理  可知要么sumod[]==0 要么sumod[i]==sumod[j]  



代码示例

//#define LOCAL
#include<iostream>
#include<string.h>
#include<cstdio>
#include<math.h>
using namespace std;
const int maxn=10010;

int arr[maxn];
int sumod[maxn];
int pos[maxn];//n个余数

int main()
{
    ios::sync_with_stdio(false);
    #ifdef LOCAL
        freopen("read.txt","r",stdin);
    #endif
    int N;
    int temp=0;
    cin>>N;
    memset(pos,-1,sizeof(pos));
    for(int i=0;i<N;++i){
        cin>>arr[i];
    }
    for(int i=0;i<N;++i){
        temp+=arr[i];
        sumod[i]=temp%N;
        if(sumod[i]==0){
            cout<<i+1<<endl;
            for(int j=0;j<i+1;++j) cout<<arr[j]<<endl;
            break;
        }
        else{
            if(pos[sumod[i]]>=0){
                cout<<i-pos[sumod[i]]<<endl;
                for(int j=pos[sumod[i]]+1;j<=i;++j) cout<<arr[j]<<endl;
                break;
            }
            else pos[sumod[i]]=i;
        }
    }
    return 0;
}

时间复杂度为O(N)

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值