POJ - 2356 Find a multiple(鸽巢原理/抽屉原理)

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input
The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output
In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.
Sample Input
5
1
2
3
4
1
Sample Output
2
2
3

题意:
有N个数,找出其中的几个数,使他们的和为N的倍数。

思路:
鸽巢原理(抽屉原理):假如有n个元素放到n-1个集合中去,其中必定有一个集合里至少有两个元素。

用数组a[]代表这N个数,数组sum[]代表这N个数的前缀和。
要找出这几个数有三种情况:
1、这N个数内存在一个数a[i]%N=0,就可以直接输出这个数;
2、如果sum[i]%N=0,就说明从1到i这些数的和是N的倍数,输出
这些数;
3、sum[i]%N有(0 ~ N-1)这N种可能,但是等
于0的情况已经在2中考虑过了,所以到这一步就相当于只有
(1 ~ N-1)这N-1种可能,根据鸽巢原理,sum[i]%N(1<=i<=N)
这N个数中必定有两个数是相等的(因为sum[i]%N有N个数,然而
只有N-1种可能),所以可以得出对于i,j(i<j) 
存在sum[i]%N==sum[j]%N -> sum[j]%N-sum[i]%N==0 这就说
明i+1~j这些数字的和是N的倍数;

代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;

#define lowbit(a) (a & (-a))
#define ll long long
const int inf = 0x3f3f3f3f;
const int maxn = 1e4 + 10;
const int minn = 1e6 + 10;
const double PI = acos(-1.0);
#define mod 1000000007
#define eps 1e-10

int a[maxn], sum[maxn], vis[maxn];

int main()
{
    int n;
    cin >> n;
    for (int i = 1; i <= n; i++)
    {
        cin >> a[i];
        sum[i] = sum[i - 1] + a[i];
    }
    for (int i = 1; i <= n; i++)
    {
        if (a[i] % n == 0)
        {
            cout << 1 << endl;
            cout << a[i] << endl;
            break;
        }
        else if (sum[i] % n == 0)
        {
            cout << i << endl;
            for (int j = 1; j <= i; j++)
                cout << a[j] << endl;
            break;
        }
        else
        {
            if (!vis[sum[i] % n])
                vis[sum[i] % n] = i;
            else
            {
                cout << i - vis[sum[i] % n] << endl;
                for (int j = vis[sum[i] % n] + 1; j <= i; j++)
                    cout << a[j] << endl;
                break;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值