HDU 1754(线段树,单点覆盖 询问区间最值)

problem

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9

Hint

Huge input,the C function scanf() will work better than cin


思路

裸的模板题


代码示例

#include<iostream>
#include<cstdio>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
const int maxn=200010;

int maxx[maxn<<2];

void PushUp(int rt){
    maxx[rt]=max(maxx[rt<<1],maxx[rt<<1|1]);
}

void build(int l,int r,int rt){
    if(l==r){
        scanf("%d",&maxx[rt]);
        return ;
    }
    int m=(l+r)>>1;
    build(lson); build(rson);
    PushUp(rt);
}

void update(int p,int cov,int l,int r,int rt){
    if(l==r){
        maxx[rt]=cov;//这里是赋值
        return ;
    }
    int m=(l+r)>>1;
    if(p<=m) update(p,cov,lson);
    else update(p,cov,rson);
    PushUp(rt);
}

int query(int L,int R,int l,int r,int rt){
    if(L<=l&&r<=R) return maxx[rt];
    int m=(l+r)>>1;
    int ret=0;//较小数
    if(L<=m) ret=max(ret,query(L,R,lson));//维护最值
    if(R>m) ret=max(ret,query(L,R,rson));
    return ret;
}

int main()
{
    //freopen("read.txt","r",stdin);
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        build(1,n,1);
        while(m--)
        {
            char ch;
            int a,b;
            scanf("%*c %c %d %d",&ch,&a,&b);
            if(ch=='Q') printf("%d\n",query(a,b,1,n,1));
            else update(a,b,1,n,1);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值