POJ - 3048 区间数的最大质因子

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.
(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).
Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

Input

* Line 1: A single integer, N
* Lines 2..N+1: The serial numbers to be tested, one per line

Output

* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

Sample Input

4
36
38
40
42

Sample Output

38

Hint

OUTPUT DETAILS:
19 is a prime factor of 38. No other input number has a larger prime factor.

思路1

预处理出1~20000的所有素数

对于每个n,看最后整除n的素数时是多少 即是n的最大质因子

复杂度为 n2e4/ln(2e4) n ∗ 2 e 4 / l n ( 2 e 4 )

代码示例1

//暴力 复杂度为n*2e4/ln(2e4)
#include<iostream>
using namespace std;

const int maxn=2e4+10;

bool valid[maxn];
int ans[maxn];
int tot;

void get_prime(int n)
{
    tot=0;
    for(int i=2;i<=n;++i) valid[i]=true;
    for(int i=2;i<=n;++i){
        if(valid[i]){
            ans[++tot]=i;
        }
        for(int j=1;j<=tot && ans[j] * i <=n ;++j){
            valid[i*ans[j]]=false;
            if(i%ans[j]==0) break;
        }
    }
}

int main()
{
    get_prime(2e4);
    int t,n,Ans,res;
    cin>>t;
    res=2;
    int sum=t;
    while(t--)
    {
        cin>>n;
        sum-=n;
        for(int i=1;i<=tot && ans[i]<=n;++i){
            if(n%ans[i]==0 && ans[i]>res){
                Ans=n;
                res=ans[i];
            }
        }
    }
    if(sum==0) cout<<1<<endl;
    else cout<<Ans<<endl;
    return 0;
}

思路2 优化

在埃筛中我们用质数的倍数去筛区间

所有的合数会被质因子筛去

那我们可以留下最大的这样的质因子

for(int i=2;i<=n;++i) ans[i]=i;
    for(int i=2;i<=n;++i){
        if(ans[i]==i){//素数
            for(int j=i*2;j<=n;j+=i)
                ans[j]=i;
        }
    }

注意这里不能提前n/i < i break 因为我们要留下最大的质因子 而不是仅仅筛去

下面j=i*2 而不是i * i 同理

时间复杂度O(nlogn)

代码示例2

 //筛法求 1~n 内数的最大质因数  O(nlogn)
#include<iostream>
using namespace std;

const int maxn=2e4+10;

int ans[maxn];//数的最大质因子 素数就是自己
int tot;

void get_prime(int n)
{
    for(int i=2;i<=n;++i) ans[i]=i;
    for(int i=2;i<=n;++i){
        if(ans[i]==i){//素数
            for(int j=i*2;j<=n;j+=i)
                ans[j]=i;
        }
    }
}

int main()
{
    get_prime(2e4);
    int t,n,res,Ans;
    cin>>t;
    int sum=t;
    res=2;
    while(t--)
    {
        cin>>n;
        sum-=n;
        if(ans[n]>res){
            res=ans[n];
            Ans=n;
        }
    }
    if(sum==0) cout<<1<<endl;
    else cout<<Ans<<endl;
    return 0;
}

思考

在素数背景下

遇到区间的问题

要尽量往筛法 上思考 往往可以将 n2/logn n 2 / l o g n 的 复杂度优化为 nlogn n l o g n


比如经典的埃拉托斯特尼素数筛法欧拉线性筛法


埃塞时间不敌线性筛 但是其能保留一些有效的信息

比如这里的①数的最大质因子

垃圾变宝贝了(:


埃塞还能处理②大区间的素数筛
http://blog.csdn.net/feynman1999/article/details/79533130



对于欧拉素数筛

所有线性筛积性函数都必须基于线性筛素数

这两种方法都是经典的

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值