Max Factor(找最大素数)

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.      

Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line
Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
Sample Input
4
36
38
40
42
Sample Output
38
Hint
OUTPUT DETAILS:
19 is a prime factor of 38. No other input number has a larger prime factor.

这些数都有因子,求出这些数字里的因子是素数的并且是最大的,然后把这个数字输出来。

刚开始用的最笨的方法,先建一个素数表,(是不是素数),然后把给出的数字的因子全部都列举出来,比较大小。

之后看题解,发现了一个更没得说的一个做法:打表的时候,直接把他的最大的素数因子给存进去了,直接比较就可以,很溜额。



#if 1
#include<iostream>
#include<cstring>
using namespace std;
int prime[20010];

void fun() 
{
	for(int i=0; i<=20010; i++)
		prime[i]=1;
	
	for(int i=2; i<=20010; i++) 
	{
		if(prime[i]==1)   
		{
			prime[i]=i;
			for(int j=2; i*j<=20010; j++)
			{
				prime[i*j]=i; 
			}                                                                                     
		}     
	}    
}

int main()
{
	int n; 
	fun();
	
	//cout<<prime[38]<<endl;
	while(cin>>n)
	{
		
		int endx=-1,endy=-1;
		
		for(int i=0; i<n; i++)
		{
			int x;
			cin>>x;
			if(prime[x]>endx)
			{
				endx=prime[x];
				endy=x;
			}
		}
		
		cout<<endy<<endl;
	}
	
}

#endif





  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值