poj 2352(树状数组)

problem

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
img
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

思路

考虑横坐标只表示数字出现的顺序,实质上类似于求逆序对数的思想

对于星图,我们从左往右,从下到上依次去看,查询1~a[i].y(纵坐标)中有多少个

然后将当前点i的y所对应的值+1

由于数字较小 可以不用离散化

但要注意树状数组的上界是元素值 而不是个数 (因为没有离散化)

还有就是y可能为0 注意+1

离散化不存在该问题

代码示例

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn=35000;

typedef long long ll;
typedef pair<int,int >pir;

int node[maxn];
int a[maxn];
pir c[maxn];
int n;

inline int lowbit(int x)
{
    return x&(-x);
}

void add(int a,int b)
{
    for(int i=a;i<=maxn-1;i+=lowbit(i)){//没有离散化
        node[i]+=b;
    }
}

int sum(int m)//前缀和
{
    int res=0;
    for(int i=m;i;i-=lowbit(i)){
        res+=node[i];
    }
    return res;
}

int level[maxn];

int main()
{
    //freopen("in.txt","r",stdin);
    ios::sync_with_stdio(false);
    cin>>n;
    for(int i=1;i<=n;++i){
        cin>>c[i].first>>c[i].second;
        c[i].second++;
    }
    sort(c+1,c+n+1);
//    for(int i=1;i<=n;++i){
//        cout<<c[i].first<<' '<<c[i].second<<endl;
//    }
    for(int i=1;i<=n;++i){
        a[i]=c[i].second;
    }
    for(int i=1;i<=n;++i){
        level[sum(a[i])]++;
        //cout<<sum(a[i])<<endl;
        add(a[i],1);
    }
    for(int i=0;i<=n-1;++i){
        cout<<level[i]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值