HDU 2899(一元高次函数最值)

problem

Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

思路

其最值

其最值在驻点(导函数零点)或端点处产生

牛顿迭代法求出其导函数的零点即可

代码示例

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int debug_num=0;
#define debug cout<<"debug "<<++debug_num<<" :"

double y;

double daodao(double x)
{
    return (42*6*pow(x,5)+48*5*pow(x,4)+21*2*x+10);
}

double dao(double x)
{
    return (42*pow(x,6)+48*pow(x,5)+21*x*x+10*x-y);
}

double f(double x)
{
    return (6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*x*x-y*x);
}

vector<double> res;

int main()
{
    //freopen("in.txt","r",stdin);
    //ios::sync_with_stdio(false);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        res.clear();
        scanf("%lf",&y);
        //from 0 and 100  two close
        //cout<<ans1<<' '<<ans2<<endl;
        int flag=0;
        for(double ans=0;ans<=100-0.5;ans=ans+0.5){
            if(f(ans)*f(ans+0.5)>=0) continue;
            double t=ans;
            for(int i=0;i<20;++i){
                t=t-dao(t)/daodao(t);
            }
            if(t>=0&&t<=100){
                //printf("%.4lf\n",t);
                res.push_back(t);
            }
        }
        double minn=1;
        for(int i=0;i<res.size();++i){
            //cout<<res[i]<<endl;
            minn=min(minn,f(res[i]));
        }
        minn=min(minn,f(0));
        minn=min(minn,f(100));
        printf("%.4lf\n",minn);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值