HDU2899

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13862    Accepted Submission(s): 9165


 

Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

 

Sample Input
 
2 100 200
 

 

Sample Output
 
-74.4291 -178.8534

现在,这是一个功能:
   F(x)= 6 * x ^ 7 + 8 * x ^ 6 + 7 * x ^ 3 + 5 * x ^ 2-y * x(0 <= x <= 100)
当x在0到100之间时,您能找到最小值吗?
 

输入值
输入的第一行包含一个整数T(1 <= T <= 100),它表示测试用例的数量。 然后是T行,每行只有一个实数Y。(0 <Y <1e10)
 

输出量
当x在0到100之间时,仅是最小值(精确到小数点后4位)。
 

样本输入
2
100
200
 

样本输出
-74.4291
-178.8534


思路:这道题来说偏向数学,求函数的最小值,那么数学上我们求导就可以了,求出导函数再对导函数求导,发现导函数递增,那么导函数存在零点,我们求出这个零点就可以找到函数最小值。求零点的过程用二分。


总结:单调一定可二分,二分能用不一定单调。

二分的本质是:如果找到一个性质,把整个区间一分为二,一半满足,一半不满足,那么二分可以找到这个边界点。

对于求极值/最大值/最小值无法直接用二分的时候,可以尝试用数学工具求导来看看其有没有单调性。


代码上的总结:以后求次方别用pow,有精度问题


#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long LL;
int  t;	  给予的思路 
double y; ///求次方别用pow 
double bsearch(double l,double r)
{
	const double res=1e-12;
	while(r-l>res)
	{
		double mid=(l+r)/2;
		if(42*mid*mid*mid*mid*mid*mid+48*mid*mid*mid*mid*mid+21*mid*mid+10*mid-y>=0) r=mid;
		else l=mid;
	}
return r;	
}

int main(void)
{
	cin>>t;
	while(t--)
	{
		cin>>y;
		double p=bsearch(0,100);
		printf("%.4lf\n",6*p*p*p*p*p*p*p+8*p*p*p*p*p*p+7*p*p*p+5*p*p-y*p);
	}
return 0;	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值