PAT B1046 Shortest Distance (20分)

题目:

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

 

Sample Output:

3
10
7

思路1:按照相隔点数少的计算距离,再用total_round减去它,取较小者作为最短距离。3号测试点运行超时

思路2:读取输入时,存储每个点顺时针到点1的距离,两点到点1的距离差便是两点之间顺时针的距离,再计算两点之间逆时针的距离,取其较小者。

思路1代码:

#include<iostream>

using namespace std;

int main()
{
    int n;
    cin >> n;
    int dis[n];
    int total_round = 0;
    for(int i=0; i<n; i++)
    {
        cin >> dis[i];
        total_round += dis[i];
    }
    int m;
    cin >> m;
    for(int i=0; i<m; i++)
    {
        int p, q;
        cin >> p >> q;
        if(p>q)
        {
            int temp = p;
            p = q;
            q = temp;
        }
        if(p-q > n/2)
        {
            int temp = p;
            p = q;
            q = temp;
        }
        int long_dis =0;
        for(; p%n!=q; p++)
            long_dis += dis[(p-1)%n];
        long_dis = (total_round - long_dis) > long_dis ? long_dis :total_round-long_dis;
        cout << long_dis << endl;
    }
    return 0;
}

思路2代码:

#include<iostream>

using namespace std;

int main()
{
    int n;
    cin >> n;
    int dis[n];
    int shun_dis[n]; shun_dis[0] = 0;
    int total_round = 0;
    for(int i=0; i<n; i++)
    {
        cin >> dis[i];
        total_round += dis[i];
        if(i>0)
            shun_dis[i] = shun_dis[i-1] + dis[i-1];
    }
    int m;
    cin >> m;
    for(int i=0; i<m; i++)
    {
        int p, q;
        cin >> p >> q;
        p--; q--;
        if(p>q)
        {
            int temp = p;
            p = q;
            q = temp;
        }
        int long_dis = shun_dis[q] - shun_dis[p];
        long_dis = (total_round - long_dis) > long_dis ? long_dis :total_round-long_dis;
        cout << long_dis << endl;
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值