动态规划(DP)-01背包问题-(百练)1163:The Triangle

描述
在这里插入图片描述
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

输出

Your program is to write to standard output. The highest sum is written as an integer.

样例输入
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

样例输出
30

先用暴力枚举方法:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int N;
vector<vector<int>>arr;
int f(int i,int j){
	if(i==N)//临界条件 
		return 0;
	return max(f(i+1,j),f(i+1,j+1))+arr[i][j];//要么往下一层的左边 往下一层的右边 
}
int main(){
	cin>>N;
	arr.resize(N);
	for(int i=0;i<N;i++){
		arr[i].resize(N);
		fill(arr[i].begin(),arr[i].end(),0);
	}
	for(int i=0;i<N;i++)
		for(int j=0;j<=i;j++)//输入数据类似于输出直角三角形模板 
		cin>>arr[i][j];
	cout<<f(0,0);
	return 0;
}

进行打表:
在这里插入图片描述
这种方法必定 Time Limit Exceeded,但是推动态规划的必要途径,从中可以推出
在这里插入图片描述
DPCode:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int N;
vector<vector<int>>arr;
vector<int>dp;
int main(){
	cin>>N;
	arr.resize(N);
	dp.resize(N+1);
	for(int i=0;i<N;i++){
		arr[i].resize(N);
		fill(arr[i].begin(),arr[i].end(),0);
	}
	for(int i=0;i<N;i++)
		for(int j=0;j<=i;j++)//输入数据类似于输出直角三角形模板 
		cin>>arr[i][j];
	for(int i=N-1;i>=0;--i)
		for(int j=0;j<=i;j++)
			dp[j]=max(dp[j],dp[j+1])+arr[i][j];
	cout<<dp[0];
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值