20131202_ISBN号码

试题编号201312-2
试题名称ISBN号码
试题描述每一本正式出版的图书都有一个ISBN号码与之对应,ISBN码包括9位数字、1位识别码和3位分隔符,其规定格式如“x-xxx-xxxxx-x”,其中符号“-”是分隔符(键盘上的减号),最后一位是识别码,例如0-670-82162-4就是一个标准的ISBN码。ISBN码的首位数字表示书籍的出版语言,例如0代表英语;第一个分隔符“-”之后的三位数字代表出版社,例如670代表维京出版社;第二个分隔之后的五位数字代表该书在出版社的编号;最后一位为识别码。识别码的计算方法如下:首位数字乘以1加上次位数字乘以2……以此类推,用所得的结果mod 11,所得的余数即为识别码,如果余数为10,则识别码为大写字母X。例如ISBN号码0-670-82162-4中的识别码4是这样得到的:对067082162这9个数字,从左至右,分别乘以1,2,…,9,再求和,即0×1+6×2+……+2×9=158,然后取158 mod 11的结果4作为识别码。编写程序判断输入的ISBN号码中识别码是否正确,如果正确,则仅输出“Right”;如果错误,则输出是正确的ISBN号码。
输入输入只有一行,是一个字符序列,表示一本书的ISBN号码(保证输入符合ISBN号码的格式要求)
输出输出一行,假如输入的ISBN号码的识别码正确,那么输出“Right”,否则,按照规定的格式,输出正确的ISBN号码(包括分隔符“-”)。
样例输入10-670-82162-4
样例输出1Right
样例输入20-670-82162-0
样例输出20-670-82162-4
#include <iostream>
#include <string>
using namespace std;

int main()
{
	string s;
	cin >> s;
	int sum = 0, j = 1;;
	int len = s.length() - 1;
	for (int i = 0; i < len; i++)
	{
		if (s[i] != '-')
		{
			sum += (j++) * (s[i] - '0');
		}
	}
	char c;
	c = sum % 11;
	if (c == 10)
		c = 'X';
	else
		c = '0' + c;
	if (c == s[len])
		cout << "Right" << endl;
	else
	{
		s[len] = c;
		cout << s << endl;
	}
	return 0;
}
package main.java.reader.bean; public class BForm { String jy_id,jy_name,b_isbn,b_name; String jy_date,gh_date,is_gh; int jy_count; public String getJy_id() { return jy_id; } public void setJy_id(String jy_id) { this.jy_id = jy_id; } public String getJy_name() { return jy_name; } public void setJy_name(String jy_name) { this.jy_name = jy_name; } public String getB_isbn() { return b_isbn; } public void setB_isbn(String b_isbn) { this.b_isbn = b_isbn; } public String getB_name() { return b_name; } public void setB_name(String b_name) { this.b_name = b_name; } public String getJy_date() { return jy_date; } public void setJy_date(String jy_date) { this.jy_date = jy_date; } public String getGh_date() { return gh_date; } public void setGh_date(String string) { this.gh_date = string; } public String getIs_gh() { return is_gh; } public void setIs_gh(String is_gh) { this.is_gh = is_gh; } public int getJy_count() { return jy_count; } public void setJy_count(int jy_count) { this.jy_count = jy_count; } @Override public String toString() { return "BForm [jy_id=" + jy_id + ", jy_name=" + jy_name + ", b_isbn=" + b_isbn + ", b_name=" + b_name + ", jy_date=" + jy_date + ", gh_date=" + gh_date + "]"; } public BForm() { super(); // TODO Auto-generated constructor stub } public BForm(String jy_id, String jy_name, String b_isbn, String b_name, String jy_date, String gh_date) { super(); this.jy_id = jy_id; this.jy_name = jy_name; this.b_isbn = b_isbn; this.b_name = b_name; this.jy_date = jy_date; this.gh_date = gh_date; } }
06-11
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值