PAT真题练习(甲级)1016 Phone Bills (25 分)

PAT真题练习(甲级)1016 Phone Bills (25 分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10 10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

一点想法

  1. 读取到的通话时间顺序是乱序的,因此对读入的记录根据时间进行再排序(这里我用了set容器来解决这个问题)。
  2. 之前测试点2、3一直通不过,后来发现是因为没有匹配消费记录(即Total amount = 0的消费者)不应该被输出。
  3. “on-line”和“off-line”不是一一匹配的,要判断

AC代码

#include<iostream>
#include <string>
#include <stdio.h>
#include <math.h>
#include <map>
#include <set>
using namespace std;

// 定义时间的结构体
struct Time {
	Time(string t) {
		mouth = stoi(t.substr(0, 2));
		day = stoi(t.substr(3, 2));
		hour = stoi(t.substr(6, 2));
		minute = stoi(t.substr(9, 2));
	}
	int mouth;
	int day;
	int hour;
	int minute;
};

// 时间记录的结构体
struct TimeRecord {
	TimeRecord(string t,string p):time(t),type(p){}
	string time;
	string type;
	// 定义比较运算符,使其支持set容器
	bool operator < (const TimeRecord& r) const
	{
		return this->time < r.time;
	}
};

int main() {
	int prices[24];
	// 使用map容器,保证用户信息根据用户名的字母顺序排列
	// 使用set容器,保证读取到的通话时间信息根据顺序排列
	map<string, set<TimeRecord>> users;
	// 读入不同时间段的价格
	for (auto i = 0;i < 24;i++) {
		cin >> prices[i];
	}
	int N;
	cin >> N;
	string name,t,type;
	// 读入用户的通话记录
	for (auto i = 0;i < N;i++) {
		cin >> name >> t >> type;
		users[name].insert(TimeRecord(t, type));
	}

	for (auto pair : users) {
		//记录需要输出的信息
		string item = "";
		int total = 0;
		// 使用迭代器遍历记录通话记录的set容器
		auto iter = pair.second.begin();
		while (iter!= pair.second.end()) {
			item = "";
			int tmp = 0;
			int duration = 0;
			// 找到下一个“online”的记录
			while (iter != pair.second.end() && iter->type != "on-line") iter++;
			if (iter == pair.second.end()) break;
			// 记录通话开始的时间
			Time time_on = Time(iter->time);
			item += iter->time.substr(3, 8);
			iter++;
			if (iter == pair.second.end()) break;
			// 下一条记录不匹配,重新寻找
			if (iter->type != "off-line") continue;
			// 记录通话结束的时间
			Time time_off = Time(iter->time);
			// 记录时间信息
			item +=  " " + iter->time.substr(3, 8);
			// 计算话费大小和通话时长
			while (true) {
				if (time_on.day == time_off.day) {
					if (time_on.hour == time_off.hour) {
						tmp += (time_off.minute - time_on.minute) * prices[time_on.hour];
						duration += (time_off.minute - time_on.minute);
						break;
					}
					else {
						tmp += (60 - time_on.minute) * prices[time_on.hour];
						duration += 60 - time_on.minute;
						time_on.hour++;
						time_on.minute = 0;
					}
				}
				else {
					tmp += (60 - time_on.minute) * prices[time_on.hour];
					duration += 60 - time_on.minute;
					time_on.hour++;
					time_on.minute = 0;
					if (time_on.hour == 24) {
						time_on.hour = 0;
						time_on.day++;
					}
				}
			}
			iter++;
			// 若产生了消费则输出用户名字 及月份
			if (total == 0 && tmp != 0) {
				cout << pair.first << " " << pair.second.begin()->time.substr(0, 2) << endl;
			}
			total += tmp;
			// 如果没有消费记录,则不输出
			if (tmp != 0) {
				cout << item;
				printf(" %d $%.2f\n", duration, tmp / 100.0);
			}
		}

		// 如果没有消费记录,则不输出
		if (total != 0) {
			printf("Total amount: $%.2f\n", total / 100.0);
		}
		
	}
	
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值