A1016 Phone Bills (25 分)(计算话费)(排序)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

思路:

 算法分为三部分:对所有记录排序;判断每个用户是否存在有效通话;如果有效输出所有记录并计算资费

  1. 定义结构体,存放信息,bool status;//status==true表示该记录为on-line,否则为off-line;定义排序规则,按照用户名、月、日、小时、分钟,依次排序。这样排序的话,同一用户的通话记录会按照时间顺序排好
  2. 定义needPrint表示某一个用户是否有有效通话记录:按顺序第一次遇到online记录,第二次遇到offline
  3. 输出所有有效通话记录:online和offline的排序差1
  4. 计算时长、资费:不断加1 ,判断是否到达终止时间
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
    
const int maxn = 1010;
int toll[25];//资费
struct Record
{
    char name[25];          //姓名
    int month, dd, hh, mm;  //月份、日、时、分
    bool status;            //status==true表示该记录为on-line,否则为off-line
}rec[maxn],temp;

bool cmp(Record a, Record b)
{
    int s = strcmp(a.name, b.name);
    if (s != 0)return s < 0;//优先按名字典序从小到大排序
    else if (a.month != b.month)return a.month < b.month;//按月份从小到大排序
    else if (a.dd != b.dd)return a.dd < b.dd;//按日期从小到大排序
    else if (a.hh != b.hh)return a.hh < b.hh;//按小时从小到大排序
    else return a.mm < b.mm;//按分钟从小到大排序
}
void get_ans(int on, int off, int &time, int &money)
{
    temp = rec[on];
    while (temp.dd < rec[off].dd || temp.hh < rec[off].hh || temp.mm < rec[off].mm)
    {
        time++;                     //该次记录总时间加一分钟
        money += toll[temp.hh];     //话费增加toll[temp.hh]
        temp.mm++;                  //当前时间加1min
        if (temp.mm >= 60)          //当前分钟数达到60
        {
            temp.mm = 0;            //进入下一个小时
            temp.hh++;
        }
        if (temp.hh >= 24)          //当前小时数达到24
        {
            temp.hh = 0;            //进入下一天
            temp.dd++;

        }
    }
}

int main()
{
    for (int i = 0; i < 24; i++)
    {
        scanf("%d", &toll[i]);//资费
    }
    int n;
    scanf("%d", &n);    //记录数
    char line[10];      //临时存放on-line或off-line的输入
    for (int i = 0; i < n; i++)
    {
        scanf("%s", rec[i].name);
        scanf("%d:%d:%d:%d", &rec[i].month, &rec[i].dd, &rec[i].hh, &rec[i].mm);
        scanf("%s", line);
        if (strcmp(line, "on-line") == 0)
        {
            rec[i].status = true;   //如果是on-line,则令status为true
        }
        else
        {
            rec[i].status = false;  //如果是off-line,则令status为false
        }
    }
    sort(rec, rec + n, cmp);        //排序
    int on = 0, off, next;          //on和off为配对的两条记录,next为下一个用户
    while (on < n)
    {
        int needPrint = 0;          //needPrint表示该用户是否需要输出
        next = on;                  //从当前位置开始寻找下一个用户
        //while循环看当前用户是否需要输出
        while (next < n && strcmp(rec[next].name, rec[on].name) == 0)
        {
            if (needPrint == 0 && rec[next].status == true)
            {
                needPrint = 1;      //找到on,置needPrint为1
            }
            else if (needPrint == 1 && rec[next].status == false)
            {
                needPrint = 2;      //在on之后如果找到off,置needPrint为2
            }
            next++;                 //next自增,直到找到不同名字,即下一个用户
        }
        //当前用户没有配对,找下一个用户
        if (needPrint < 2)          //没有找到配对的on-off
        {
            on = next;
            continue;
        }
        //用户可以配对
        int AllMoney = 0;//总共花费的钱
        printf("%s %02d\n", rec[on].name, rec[on].month);
        while (on < next)       //寻找该用户的所有配对
        {
            while (on < next - 1 && !(rec[on].status == true && rec[on + 1].status == false))
            {
                on++;           //直到找到连续的on-line和off-line
            }
            off = on +1;        //off必须是on的下一个
            if (off == next)    //已经输出完毕所有配对的on-line和off-line
            {
                on = next;
                break;
            }
            printf("%02d:%02d:%02d ", rec[on].dd, rec[on].hh, rec[on].mm);
            printf("%02d:%02d:%02d ", rec[off].dd, rec[off].hh, rec[off].mm);
            int time = 0, money = 0;//时间、单次记录花费的钱
            get_ans(on, off, time, money);//计算on到off内的时间和金钱
            AllMoney += money;//总金额加上该次记录的钱
            printf("%d $%.2f\n", time, money / 100.0);
            on = off + 1;//完成一个配对,从off+1开始找下一对
        }
        printf("Total amount: $%.2f\n", AllMoney / 100.0);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值