Satellite Photographs(USACO 2005 November Bronze)

11 篇文章 0 订阅

Satellite Photographs

题目链接-POJ 3051.Satellite Photographs
题目链接-SWUST OJ 0001.Satellite Photographs
Description

Farmer John purchased satellite photos of W x H pixels of his farm (1 <= W <= 80, 1 <= H <= 1000) and wishes to determine the largest ‘contiguous’ (connected) pasture. Pastures are contiguous when any pair of pixels in a pasture can be connected by traversing adjacent vertical or horizontal pixels that are part of the pasture. (It is easy to create pastures with very strange shapes, even circles that surround other circles.)

Each photo has been digitally enhanced to show pasture area as an asterisk (’*’) and non-pasture area as a period (’.’). Here is a 10 x 5 sample satellite photo:

…**
.***
.

.
…*.

This photo shows three contiguous pastures of 4, 16, and 6 pixels. Help FJ find the largest contiguous pasture in each of his satellite photos.
Input

  • Line 1: Two space-separated integers: W and H

  • Lines 2…H+1: Each line contains W “*” or “.” characters representing one raster line of a satellite photograph.
    Output

  • Line 1: The size of the largest contiguous field in the satellite photo.

Sample Input

10 5
..*.....**
.**..*****
.*...*....
..****.***
..****.***

Sample Output

16

题目大意
一个卫星图片有 ’ * ’ 和 ’ . ’ 两种符号组成,查询由 ’ * ’ 组成的最大面积

解题思路
连通块问题,dfs简单题

  • 两重for循环遍历将矩阵搜索一次,当有 ’ * ’ 的时候就在相邻的位置进行查找,如果找到 ’ * ’ 就要把面积加1,并把 ’ * ’ 变成 ’ . ’ ,避免重复记录
  • 深搜的目的就是要对以(x,y)为中心,对周围进行搜索,直到出现没有’ * '时停止,不用再用vis[][]函数标记走过的路,将 ’ * ’ 改变成 ’ . ’ 就起到了标记的作用
  • 然后我们用一个sum变量来计数,ans=max(ans,sum)函数更新最大值.
  • 坑点:h是行,w是列,一定要看清!!!

附上代码

#include<bits/stdc++.h>
using namespace std;
int way[4][2]={1,0,-1,0,0,1,0,-1};
char pho[1005][85];
int w,h;
int sum;
void dfs(int i,int j){
	for(int k=0;k<4;k++){
		int x=i+way[k][0];
		int y=j+way[k][1];
		if(x>=0&&x<h&&y>=0&&y<w&&pho[x][y]=='*'){
			sum++;
			pho[x][y]='.';
			dfs(x,y);
		}	
	}
}
int main(){
	int ans=-1;
	cin>>w>>h;
	for(int i=0;i<h;i++){
		scanf("%s",pho[i]);
	}
	for(int i=0;i<h;i++){
		for(int j=0;j<w;j++){
			if(pho[i][j]=='*'){
				sum=1;
				pho[i][j]='.';
				dfs(i,j);
				ans=max(ans,sum);
			}
		}
	}
	cout<<ans<<endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值