1/20集训一 STL G.(multimap 找出标准形式只出现一次的单词,并按字典序输出原单词)Ananagrams

1/20集训一 STL

G.(multimap 找出标准形式只出现一次的单词,并按字典序输出原单词)Ananagrams

Most crossword puzzle fans are used to
anagrams— groups of words with the same letters in different orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams , an example is QUIZ.
Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a
relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.
Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.
Input
Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.
Output
Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.
Sample Input
ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries
#
Sample Output
Disk
NotE
derail
drIed
eye
ladder
soon

题意:
对于一个单词如果能通过字符组合成另一个单词就说这两个单词是一样的,例如 OPTS,SPOT,STOP,POTS 和 POST 这些都是一样的。
现在给出一个文本, 要求找出其中满足要求:该单词通过字母组合不能构成其他在文本串中出现过的单词, 并按字典序升序输出。
Ps: 判断单词相同时不区分大小写, 输出单词时要按原单词输出。

思路:
1、如何判断两个单词相同: 我们可以将所有单词都变成全小写字符, 然后按照字典序排序, 变成标准单词, 如果两个单词对应的标准单词相同, 那么就说这两个单词相同。
2、建立标准单词到原单词的映射, 因为一个标准单词可能对于多
个原单词, 所以应该用 multimap, 允许出现重复的键值。
3、用count函数计数, 如果 multimap 中一个键值只存在一个, 那么就是我们要求的答案。
4、如何将单词按照字典序输出?
我们可以将单词放到 vector 中, 然后利用 sort函数排序
或者 直接将单词放入 set 中, 因为 set 是从小到大排序的。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string>
#include <map>
#define MAXN 1020

using namespace std;

int main()
{
    string a, b;
    multimap<string, string> s;
    string ans[MAXN];
    int num = 0;
    while(cin>>a)
    {
        if(a == "#")
            break;
        b = a;
        transform(b.begin(), b.end(), b.begin(), ::toupper);
        sort(b.begin(), b.end());
        s.insert(pair<string, string>(b, a));
    }
    multimap<string, string>::iterator iter;
    for(iter = s.begin(); iter != s.end(); iter++)
    {
        if(s.count(iter->first) == 1)
        {
            ans[num++] = iter->second;
        }
    }
    sort(ans, ans + num);
    for(int i = 0; i < num; i++)
        cout<<ans[i]<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值