Calculate the formula
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 7770 Accepted Submission(s): 2393
Problem Description
You just need to calculate the sum of the formula: 1^2+3^2+5^2+……+ n ^2.
Input
In each case, there is an odd positive integer n.
Output
Print the sum. Make sure the sum will not exceed 2^31-1
Sample Input
3
Sample Output
10
Author
wangye
Source
水题……打表
#include <iostream>
using namespace std;
__int64 x[10000];
int main()
{
int m,n,i;
x[1]=1;
for(i=3;i<=10000;i++)
{
x[i]=x[i-2]+i*i;
}
while (cin>>n)
{
printf("%I64d\n",x[n]);
}
return 0;
}