uva 10025 - The ? 1 ? 2 ? ... ? n = k problem


 The ? 1 ? 2 ? ... ? n = k problem 

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701


乍一看没思路,写几个试试

num      maxsum

1               1
2               3
3               6
4               10
5               15

6                21

7               28

感觉12<15因该是5个数字表示可是它是7个

于是发现问题,一个数字n能否用m个数字的表示条件是首先m个数字全部加起来大于n,全取+;

如果全部加起来大于n还要满足第二个条件就是m个数字和减去n必须是偶数,拿12做例子,5个数字和为15,要编程12必须-3,由于之前都是+现在必然要把某几个数字改为-,

+x变为-x,少了2x,所以减少的只能是偶数,所以5个不行6个是21不行所以是7个,然后负数相当于原来正负号取反,

0比较特殊1-2+3;

规律找到了还是错了很多次,原因就是实数的精度问题;

m*(m+1)/2=n

m=(-1+sqrt(1+4*2n))/2  wrong了好几次,估计由于精度丢失导致有几个数字的m算出来比实际的大╮(╯▽╰)╭。

办法就是算出的值让他略小于实际m值;

可以m=sqrt(2*n); 忽略m+1为m;或者算出的m减去一个小的常数,本人-10过了,当然-10之后小于0要重新赋值。

 

#include<stdio.h>
#include<math.h>
void main()
{int m,n,t,s;
 scanf("%d",&t);
 while (t--)
 {scanf("%d",&n);
  if (n==0) m=3;
  else
  {
  if (n<0) n=-n;
  m=(-1+sqrt(1+8*n))/2-10;
  if (m<1) m=1;
  s=m*(m+1)/2;
  while ((s<n)||((s-n)%2==1))
  {++m;s=m*(m+1)/2;}
  }
  printf("%d\n",m);
  if (t) printf("\n");
 }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
当然可以,以下是基于标准库的VEML6040传感器读取代码示例: ```c #include "stdio.h" #include "stdlib.h" #include "string.h" #include "stm32f4xx.h" #define I2C_ADDRESS 0x10<<1 // I2C地址为0x10 #define VEML6040_REG_CONF 0x00 // 寄存器配置地址 #define VEML6040_REG_UVA 0x07 // UVA数据寄存器地址 #define VEML6040_REG_DYN_RANGE 0x06 // 动态范围寄存器地址 I2C_TypeDef* I2Cx = I2C1; void I2C_Init() { GPIO_InitTypeDef GPIO_InitStruct; I2C_InitTypeDef I2C_InitStruct; RCC_AHB1PeriphClockCmd(RCC_AHB1Periph_GPIOB, ENABLE); RCC_APB1PeriphClockCmd(RCC_APB1Periph_I2C1, ENABLE); GPIO_InitStruct.GPIO_Pin = GPIO_Pin_6 | GPIO_Pin_7; GPIO_InitStruct.GPIO_Mode = GPIO_Mode_AF; GPIO_InitStruct.GPIO_Speed = GPIO_Speed_50MHz; GPIO_InitStruct.GPIO_OType = GPIO_OType_OD; GPIO_InitStruct.GPIO_PuPd = GPIO_PuPd_UP; GPIO_Init(GPIOB, &GPIO_InitStruct); GPIO_PinAFConfig(GPIOB, GPIO_PinSource6, GPIO_AF_I2C1); GPIO_PinAFConfig(GPIOB, GPIO_PinSource7, GPIO_AF_I2C1); I2C_InitStruct.I2C_Mode = I2C_Mode_I2C; I2C_InitStruct.I2C_DutyCycle = I2C_DutyCycle_2; I2C_InitStruct.I2C_OwnAddress1 = 0x00; I2C_InitStruct.I2C_Ack = I2C_Ack_Enable; I2C_InitStruct.I2C_AcknowledgedAddress = I2C_AcknowledgedAddress_7bit; I2C_InitStruct.I2C_ClockSpeed = 100000; I2C_Init(I2Cx, &I2C_InitStruct); I2C_Cmd(I2Cx, ENABLE); } // 写入字节到VEML6040寄存器 void VEML6040_WriteByte(uint8_t reg, uint8_t val) { while (I2C_GetFlagStatus(I2Cx, I2C_FLAG_BUSY)) {} I2C_GenerateSTART(I2Cx, ENABLE); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_MODE_SELECT)) {} I2C_Send7bitAddress(I2Cx, I2C_ADDRESS, I2C_Direction_Transmitter); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_TRANSMITTER_MODE_SELECTED)) {} I2C_SendData(I2Cx, reg); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_BYTE_TRANSMITTED)) {} I2C_SendData(I2Cx, val); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_BYTE_TRANSMITTED)) {} I2C_GenerateSTOP(I2Cx, ENABLE); } // 从VEML6040寄存器读取字节 uint8_t VEML6040_ReadByte(uint8_t reg) { uint8_t data; while (I2C_GetFlagStatus(I2Cx, I2C_FLAG_BUSY)) {} I2C_GenerateSTART(I2Cx, ENABLE); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_MODE_SELECT)) {} I2C_Send7bitAddress(I2Cx, I2C_ADDRESS, I2C_Direction_Transmitter); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_TRANSMITTER_MODE_SELECTED)) {} I2C_SendData(I2Cx, reg); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_BYTE_TRANSMITTED)) {} I2C_GenerateSTART(I2Cx, ENABLE); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_MODE_SELECT)) {} I2C_Send7bitAddress(I2Cx, I2C_ADDRESS, I2C_Direction_Receiver); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_RECEIVER_MODE_SELECTED)) {} while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_BYTE_RECEIVED)) {} data = I2C_ReceiveData(I2Cx); I2C_GenerateSTOP(I2Cx, ENABLE); return data; } // 初始化VEML6040传感器 void VEML6040_Init() { VEML6040_WriteByte(VEML6040_REG_CONF, 0x00); // 将配置寄存器设置为默认值 VEML6040_WriteByte(VEML6040_REG_DYN_RANGE, 0x00); // 将动态范围设置为默认值 } // 读取VEML6040传感器的UVA数据 uint16_t VEML6040_ReadUVA() { uint8_t data[2]; while (I2C_GetFlagStatus(I2Cx, I2C_FLAG_BUSY)) {} I2C_GenerateSTART(I2Cx, ENABLE); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_MODE_SELECT)) {} I2C_Send7bitAddress(I2Cx, I2C_ADDRESS, I2C_Direction_Transmitter); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_TRANSMITTER_MODE_SELECTED)) {} I2C_SendData(I2Cx, VEML6040_REG_UVA); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_BYTE_TRANSMITTED)) {} I2C_GenerateSTART(I2Cx, ENABLE); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_MODE_SELECT)) {} I2C_Send7bitAddress(I2Cx, I2C_ADDRESS, I2C_Direction_Receiver); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_RECEIVER_MODE_SELECTED)) {} while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_BYTE_RECEIVED)) {} data[0] = I2C_ReceiveData(I2Cx); I2C_AcknowledgeConfig(I2Cx, ENABLE); while (!I2C_CheckEvent(I2Cx, I2C_EVENT_MASTER_BYTE_RECEIVED)) {} data[1] = I2C_ReceiveData(I2Cx); I2C_GenerateSTOP(I2Cx, ENABLE); return (data[1] << 8) | data[0]; // 将读取的数据转换为16位整数 } int main(void) { I2C_Init(); // 初始化I2C VEML6040_Init(); // 初始化VEML6040传感器 while (1) { uint16_t uva = VEML6040_ReadUVA(); // 读取UVA数据 printf("UVA: %d\n", uva); // 输出UVA数据 for (int i = 0; i < 500000; i++) {} // 延时 } } ``` 在此示例中,使用标准库中的I2C_GenerateSTART()、I2C_Send7bitAddress()、I2C_SendData()、I2C_ReceiveData()和I2C_GenerateSTOP()函数来进行I2C通信。首先进行初始化,然后通过VEML6040_WriteByte()和VEML6040_ReadByte()函数操作VEML6040寄存器,最后通过VEML6040_ReadUVA()函数读取UVA数据。注意,由于使用的是标准库,因此需要手动实现一些HAL库中已经封装好的函数,如GPIO初始化和I2C初始化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值