uva 108 - Maximum Sum


Maximum Sum

Background

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

The Problem

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size tex2html_wrap_inline33 or greater located within the whole array. As an example, the maximal sub-rectangle of the array:

displaymath35

is in the lower-left-hand corner:

displaymath37

and has the sum of 15.

Input and Output

The input consists of an tex2html_wrap_inline39 array of integers. The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by tex2html_wrap_inline43 integers separated by white-space (newlines and spaces). These tex2html_wrap_inline43 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [-127, 127].

The output is the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7  0 9  2 -6  2
-4  1 -4  1 -1
8  0 -2

Sample Output

15
一维的时候是最大连续子序列问题,二维求的是矩形,可以用捆绑法转换为一维的情况,只要枚举不同的组合方法
#include<stdio.h>
#include<string.h>
#define inf -9999999
int b[101],n;
int count()
{
 int i;
 int f=1,max=inf,sum=0;
 for (i=1;i<=n;i++)
 {
  if  (b[i]>max) max=b[i];
  if (b[i]>=0)  f=0;
 }
 if (f) return max;
 for (i=1;i<=n;i++)
 {
  sum=sum+b[i];
  if (sum>max) max=sum;
  if (sum<0) sum=0;
 }
 return max;
}
int main()
{
 int i,j,k,t,a[101][101],max,ans;
 scanf("%d",&n);
 for (i=1;i<=n;i++)
 for (j=1;j<=n;j++)
 scanf("%d",&a[i][j]);
 max=inf;
 for (k=0;k<n;k++)
 {
  for (i=1;i<=n;i++)
  {
   if (i+k<=n)
   {
    memset(b,0,sizeof(b));

    for (j=i;j<=i+k;j++)
    for (t=1;t<=n;t++)
    b[t]+=a[j][t];
    ans=count();
    if (ans>max) max=ans;
   }
  }
 }
 printf("%d\n",max);
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值