HDU 1003 - Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author

Ignatius.L





考虑一个“对于前n个数最大的必须到达末尾的连续子序列”,我就把简称为MESS(Max end sub-sequence)

例如“6 -1 5 4 -7”这个数列,对于前3个数“6 -1 5”,它从末尾出发,设其和最大的子序列为MESS[3],

那么对于前四个“6 -1 5 4”,MESS[4]= (    (MESS[3]>0)     ?     (MESS[3]+num[4])     :     (num[4])    );

另外,最后遍历MESS数组,找到最大的那个值就是answer,那个位置就是子序列的末尾位置,另外为了记录子序列的开始位置,我把MESS定义成了结构体……里面定义一个sum用来存最大的和,另外定义一个begin来储存开始位置。

#include<cstdio>
int num[100003];
typedef struct{
	int sum;
	int begin;
}type;
type MESS[100003];
int main()
{
	int t,n;scanf("%d",&t);
	for(int kase=1;kase<=t;kase++){
		scanf("%d",&n);for(int i=1;i<=n;i++) scanf("%d",&num[i]);
		MESS[1].sum=num[1];MESS[1].begin=1;
		for(int i=2;i<=n;i++){
			if(MESS[i-1].sum<0){
				MESS[i].sum=num[i];
				MESS[i].begin=i;
			}
			else{
				MESS[i].sum=MESS[i-1].sum+num[i];
				MESS[i].begin=MESS[i-1].begin;
			}
		}
		type max=MESS[1];int end=1;
		for(int i=2;i<=n;i++) if(max.sum<=MESS[i].sum) {max=MESS[i];end=i;}
		if(kase>=2) printf("\n");
		printf("Case %d:\n%d %d %d\n",kase,max.sum,max.begin,end);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值