UVA140 ——bandwidth(搜索)

Given a graph (V,E) where V is a set of nodes and E is a set of arcs in VxV, and an ordering on the elements in V, then the bandwidth of a node v is defined as the maximum distance in the ordering between v and any node to which it is connected in the graph. The bandwidth of the ordering is then defined as the maximum of the individual bandwidths. For example, consider the following graph:

picture25

This can be ordered in many ways, two of which are illustrated below:

picture47

For these orderings, the bandwidths of the nodes (in order) are 6, 6, 1, 4, 1, 1, 6, 6 giving an ordering bandwidth of 6, and 5, 3, 1, 4, 3, 5, 1, 4 giving an ordering bandwidth of 5.

Write a program that will find the ordering of a graph that minimises the bandwidth.

Input

Input will consist of a series of graphs. Each graph will appear on a line by itself. The entire file will be terminated by a line consisting of a single #. For each graph, the input will consist of a series of records separated by `;'. Each record will consist of a node name (a single upper case character in the the range `A' to `Z'), followed by a `:' and at least one of its neighbours. The graph will contain no more than 8 nodes.

Output

Output will consist of one line for each graph, listing the ordering of the nodes followed by an arrow (->) and the bandwidth for that ordering. All items must be separated from their neighbours by exactly one space. If more than one ordering produces the same bandwidth, then choose the smallest in lexicographic ordering, that is the one that would appear first in an alphabetic listing.

Sample input

A:FB;B:GC;D:GC;F:AGH;E:HD
#

Sample output

A B C F G D H E -> 3

求出排列好后,相连的两个值之间存在的最大值,然后找出最大值最小的那一组


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int maps[30][30];
int hav[30];
int p[10],a[10];
int ans[10],n,pmax,sum;
int work()        //如果相连,求它们之间距离的最大值
{
    int tmax = 0;
    for(int i=1; i<n; i++)
    {
        for(int j=i+1; j<n; j++)
        {
            if(maps[a[i]][a[j]])
            {
                if(j - i>tmax)
                    tmax=j-i;
            }
        }
    }
    return tmax;
}
void dfs(int cur)
{
    int flag;
    if(cur==n)
    {
        sum=work();
        if(pmax>sum)      //找出最大距离最小的那一组
        {
            pmax=sum;
            memcpy(ans,a,sizeof(a));
        }
        return ;
    }
    else
    {
        for(int i=1; i<n; i++)
        {
            flag=1;
            a[cur]=p[i];
            for(int j=1; j<cur; j++)
            {
                if(a[j]==a[cur])
                {
                    flag=0;
                    break;
                }
            }
            if(flag)
                dfs(cur+1);
        }
    }
}
int main()
{
    char str[100];
    char c;
    int len,i,pre,now;
    while(gets(str)&&strcmp(str,"#"))
    {
        n=1,pmax = 0x3f3f3f3f;
        len=strlen(str);
        memset(maps,0,sizeof(maps));
        memset(hav,0,sizeof(hav));
        memset(p,0,sizeof(p));
        for(i=0; i<len; i++)
        {
            c=str[i];
            if(str[i+1]==':')
            {
                pre=c-'A'+1;
                hav[pre]++;
            }
            else if(c>='A'&&c<='Z')
            {
                now=c-'A'+1;
                hav[now]++;
                maps[now][pre]=maps[pre][now]=1;
            }
        }
        for(i=0; i<27; i++)
        {
            if(hav[i])
                p[n++]=i;
        }
        dfs(1);
        for(i=1; i<n; i++)
            printf("%c ",ans[i]+'A'-1);
        printf("-> %d",pmax);
        printf("\n");
    }
    return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值