poj1681 高斯消元

Painter's Problem
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5352 Accepted: 2588

Description

There is a square wall which is made of n*n small square bricks. Some bricks are white while some bricks are yellow. Bob is a painter and he wants to paint all the bricks yellow. But there is something wrong with Bob's brush. Once he uses this brush to paint brick (i, j), the bricks at (i, j), (i-1, j), (i+1, j), (i, j-1) and (i, j+1) all change their color. Your task is to find the minimum number of bricks Bob should paint in order to make all the bricks yellow. 

Input

The first line contains a single integer t (1 <= t <= 20) that indicates the number of test cases. Then follow the t cases. Each test case begins with a line contains an integer n (1 <= n <= 15), representing the size of wall. The next n lines represent the original wall. Each line contains n characters. The j-th character of the i-th line figures out the color of brick at position (i, j). We use a 'w' to express a white brick while a 'y' to express a yellow brick.

Output

For each case, output a line contains the minimum number of bricks Bob should paint. If Bob can't paint all the bricks yellow, print 'inf'.

Sample Input

2
3
yyy
yyy
yyy
5
wwwww
wwwww
wwwww
wwwww
wwwww

Sample Output

0
15


题意:

一个n*n 的木板,每个格子都可以染成白色和黄色,一旦我们对某个格子染色,其上下左右都将改变颜色

求将所有的格子染成黄色最少需要几次,若不能则输出inf。

当有多个自由变元时,需要进行枚举求出最小值

/*
poj1681
类似于一元开关问题。把二维矩阵转换成一维矩阵来看。
在求出答案之后,对于有很多解的考虑枚举自由变元来求解
最小值
*/
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
typedef long double ld;

using namespace std;
const int maxn = 300;

int equ,var;
int a[maxn][maxn];
int x[maxn];
int free_x[maxn];
int free_num;

int Gauss()
{
    int max_r,col,k;
    free_num = 0;
    for(k = 0,col = 0; k < equ && col < var; k++,col++)
    {
        max_r = k;
        for(int i = k+1; i < equ; i++)
        {
            if(abs(a[i][col]) > abs(a[max_r][col]))
                max_r = i;
        }
        if(a[max_r][col] == 0)
        {
            k --;
            free_x[free_num++] = col;
            continue;
        }
        if(max_r != k)
        {
            for(int j = col; j < var+1; j++)
                swap(a[k][j],a[max_r][j]);

        }
        for(int i = k + 1; i < equ; i++)
        {
            if(a[i][col] != 0)
            {
                for(int j = col; j < var+1; j++)
                    a[i][j] ^= a[k][j];
            }
        }

    }
    for(int i = k; i < equ; i++)
        if(a[i][col] != 0)
            return -1;
    if(k < var) return var-k;

    for(int i = var-1; i >= 0; i--)
    {
        x[i] = a[i][var];
        for(int j = i +1; j < var; j++)
            x[i] ^= (a[i][j] && x[j]);

    }
    return 0;

}

int n;
void ini()
{
    memset(a,0,sizeof(a));
    memset(x,0,sizeof(x));
    equ = n*n;
    var = n*n;
    for(int i = 0;i < n;i++)
    {
        for(int j = 0;j < n;j++)
        {
            int tt = i*n+ j;
            a[tt][tt] =1;
            if(i > 0) a[(i-1)*n+j][tt] = 1;
            if(i < n-1) a[(i+1)*n+j][tt] = 1;
            if(j > 0) a[tt-1][tt] = 1;
            if(j < n-1) a[tt+1][tt] =1;
        }
    }
}

char str[30][30];
/*
2
3
yyy
yyy
yyy
5
wwwww
wwwww
wwwww
wwwww
wwwww
*/
int main()
{
    int T;
    char color;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        ini();
        for(int i = 0; i < n; i++)
        {
            scanf("%s",str[i]);
            for(int j = 0; j < n; j++)
            {
                if(str[i][j] == 'y')
                    a[i*n+j][n*n] = 0;
                else
                    a[i*n+j][n*n] = 1;
            }
        }
        int t = Gauss();
        if(t == -1)
        {
            printf("inf\n");
        }
        else if(t == 0)
        {
            int ans = 0;
            for(int i = 0; i < n*n; i++)
                ans += x[i];
            printf("%d\n",ans);
        }
        else
        {
            int ans = 0x3f3f3f3f;
            int tot = (1 << t);
            for(int i = 0; i < tot; i++)
            {
                int cnt = 0;
                for(int j = 0; j < t; j++)
                {
                    if(i & (1 << j))
                    {
                        cnt ++;
                        x[free_x[j]]= 1;
                    }
                    else x[free_x[j]]= 0;
                }

                for(int j = var-t-1; j >= 0; j--)
                {
                    int dex;
                    for(dex = j; dex < var; dex++)
                        if(a[j][dex])
                            break;
                    x[dex] = a[j][var];
                    for(int l = dex +1; l <var ; l++)
                    {
                        if(a[j][l])
                            x[dex] ^= x[l];
                    }
                    cnt += x[dex];
                }
                ans = min(ans,cnt);
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值